CorelDRAW Graphics Suite 2022 Update (Windows and Mac) Release notes

Update 1

New and Enhanced Features

Available exclusively to subscribers and licensees with an active CorelSure Maintenance, the CorelDRAW Graphics Suite 2022 Update 1 (v24.1) brings enhancements to several areas in CorelDRAW:

  • Access personalized learning content based on your profile survey in the Welcome screen (Help > Welcome > Tutorials).
  • Rename an asset or page in the Export docker (Windows) or Export inspector (macOS) by clicking the name label and entering a new name.
  • Submit comments or suggestions about CorelDRAW Graphics Suite through an online portal by clicking Help > Submit Ideas and Feedback on Windows. The portal is available only in English. On Windows, you can customize the Submit Ideas and Feedback menu command and save the changes in a custom workspace.
  • If the application quits unexpectedly during a session on macOS, an error log report is automatically sent to Corel to help fix the problem and improve the application.
  • Padding has been added on both sides of the text on the last page of the profile survey to improve the layout.
  • When there are no exact matches for your search query in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), a message notifies you that the application will show results for similar words or characters instead.
  • When you search for menu commands in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the search results now include a list of all relevant locations for accessing the commands.
  • Now when you search for menu commands in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the Menu bar is listed before the Context menu bar in the list of locations for accessing the commands.
  • When you search for menu commands in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the search results now include the full path to the commands.
  • On the last page of the personalization survey, a message notifies you that the application is updating the list of recommended learning resources based on your profile.

Performance and Stability

CorelDRAW Graphics Suite 2022 Update 1 (v24.1) also includes performance and stability fixes for several customer-reported issues.

  • When you enable the Page option on the Advanced tab in the EPS Export dialog box, save a file to the EPS format, and then open it in Corel PHOTO-PAINT, the document now has the correct page size.
  • When you take a screen capture by using the Win+SHIFT+S keyboard shortcut on Windows 10 and Windows 11, you can now paste the contents of the Clipboard into a CorelDRAW document.
  • Curves that have transparency with a merge mode (such as 'If darker') applied to it are no longer rasterized when you export a document to the EPS format on Windows.
  • Removing JPEG compression artifacts now works as expected.
  • The UsePageBoundingBox property has been added to the PDFVBASettings class, and scripting of PDF Export Page size settings (PDF Settings > General) now works properly.
  • When setting outline properties by using VBA scripts on Windows, CorelDRAW changes the outline width as expected.
  • Performance and stability issues with zooming and panning when moving objects have been resolved.
  • Nonfunctional tools and other commands that are not needed have been removed from the toolbox in the Adobe Illustrator workspace on Windows.
  • CorelDRAW now remembers the PANTONE® color palette you choose in the Preferences (CorelDRAW menu > Preferences > Color on macOS) or Options (Tools > Options > Color on Windows) dialog box from one session to another.
  • Entering special characters, such as / and %, in the search field of the Explore tab in the Learn docker (Windows) or Learn inspector (macOS) no longer results in a "Page Not Found" error.
  • Issues with the appearance of rounded corners of the profile survey on macOS have been addressed.
  • When using the application in Turkish, Dutch, and Swedish, the Learn docker (Windows) or Learn inspector (macOS) now displays a list of learning resources in English.
  • When you right-click (Windows) or Control-click in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the context menu is no longer available by design.
  • The search results in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS) no longer disappear in the following case: with the Explore tab active, change the theme, switch to the Hints tab, and then switch back to the Explore tab.
  • Corporate users of CorelDRAW Graphics Suite who sign in to CorelDRAW.app with their corel.com or corporate Microsoft 365 accounts and open a CorelDRAW (CDR) file saved to the Cloud can now access the project dashboard as expected.
  • When you perform a search in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), and the search results match exactly your search query, you will no longer see an error message that no exact matches are found if you scroll down to the end of the list, and then scroll back to the top of the list.
  • The application no longer displays wrong search results in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS) when you clear the search or choose a different filter while the search results from your query are still loading.
  • On macOS, the application no longer stops responding if you access a flyout from the property bar, enter a value, press Enter, and then press Esc.
  • Issues with untranslated closed captions have been addressed for Hints videos that are listed in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS).
  • On Windows, you can now open a CorelDRAW (CDR), Corel DESIGNER (DES), or Corel PHOTO-PAINT (CPT) file by double-clicking the file or right-clicking the file in File Explorer, clicking Open with, and choosing CorelDRAW, or Corel PHOTO-PAINT, respectively.
  • Applying a drop shadow, an envelope, or perspective to bitmaps that are linked groups is now disabled. To apply a drop shadow, an envelope, or perspective to bitmaps that are linked groups, you must first group the bitmaps with the effects.