Notas de versão da Atualização do CorelDRAW Technical Suite 2022

Atualização de segurança (15/12/2022)

A Atualização de segurança do CorelDRAW Technical Suite 2022 (v24.2.1) inclui correções para as vulnerabilidades relatadas pela Zero Day Initiative (ZDI).

  • ZDI-22-1468 - Vulnerabilidade de divulgação de informações por leitura fora dos limites ao analisar arquivos GIF
  • ZDI-22-1469 - Vulnerabilidade de divulgação de informações por leitura fora dos limites ao analisar arquivos BMP
  • ZDI-22-1470 - Vulnerabilidade de divulgação de informações por leitura fora dos limites ao analisar arquivos JP2
  • ZDI-22-1471 - Vulnerabilidade de execução remota de código por estouro de buffer baseado em pilha ao analisar arquivos CGM
  • ZDI-22-1472 - Vulnerabilidade de execução remota de código por gravação fora dos limites ao analisar arquivos GIF
  • ZDI-22-1473 - Vulnerabilidade de divulgação de informações por leitura fora dos limites ao analisar arquivos PDF
  • ZDI-22-1474 - Vulnerabilidade de execução remota de código por leitura fora dos limites ao analisar arquivos EMF
  • ZDI-22-1475 - Vulnerabilidade de execução remota de código por gravação fora dos limites ao analisar arquivos PCX
  • ZDI-22-1476 - Vulnerabilidade de execução remota de código por gravação fora dos limites ao analisar arquivos PCX

Atualização de setembro de 2022

Recursos novos e melhorados

Disponível exclusivamente para assinantes e licenciados com um plano Manutenção CorelSure ativo, a Atualização de setembro de 2022 do CorelDRAW Technical Suite (v24.2) oferece novos recursos e melhorias em várias áreas do Corel DESIGNER, do CorelDRAW e do Corel PHOTO-PAINT:

Novo e aprimorado! Caixa de diálogo Criar um novo documento

A caixa de diálogo Criar um novo documento foi reformulada para oferecer um local centralizado onde iniciar novos desenhos. Agora, a caixa de diálogo tem duas guias, Configurações do documento e Modelos, para que você possa alternar entre as visualizações com facilidade.

Na guia Configurações do documento (Arquivo > Novo), você pode iniciar um desenho em branco especificando as configurações do documento ou escolhendo uma predefinição. Com o CorelDRAW e o Corel DESIGNER, é possível pesquisar e navegar em uma ampla seleção de predefinições para impressão, Web, dispositivos específicos e redes sociais. As predefinições incluem configurações predefinidas para o tamanho e a orientação da página, o modo de cores primárias, as unidades de medida e a resolução. Por exemplo, a predefinição Capa do LinkedIn da categoria Redes sociais usa pixels em vez de polegadas, orientação de paisagem e cores RGB e tem as dimensões necessárias para uma imagem de capa do LinkedIn. Para encontrar as predefinições com mais facilidade, o CorelDRAW e o Corel DESIGNER permitem filtrá-las por categoria e tipo de página e classificá-las por nome, data e tamanho da página.

Na guia Modelos (Arquivo > Novo baseado em modelo), você pode iniciar um desenho com base em um modelo. As interfaces para filtrar e classificar modelos, bem como acessar pastas locais e de rede, foram reorganizadas para ajudar você a encontrar os modelos necessários rapidamente.

Novo! Projetos para treinar

Os projetos para treinar são coleções de arquivos do CorelDRAW (CDR) e do Corel PHOTO-PAINT (CPT) que você pode baixar para usar para fins de aprendizagem, treinamento ou demonstração. Você pode aproveitar os novos tutoriais integrados ao app para treinar conceitos básicos e refinar suas habilidades. Além da versão finalizada do projeto, que você pode usar como referência, cada tutorial vem com uma versão parcialmente concluída, enriquecida com instruções passo a passo para tornar a experiência interativa e ajudá-lo a concluir o projeto com sucesso. Você pode acessar e procurar os projetos para treinar na guia Explorar da janela de encaixe Aprender. Responda à pesquisa sobre perfil do usuário para obter recomendações de projetos para treinar que correspondam ao seu nível de habilidade e atendam às suas necessidades de design.

Novo! Compatibilidade com o formato de arquivo de imagem do Google (*.webp)

Agora, o CorelDRAW, o Corel DESIGNER e o Corel PHOTO-PAINT oferecem compatibilidade com o formato de arquivo de imagem do Google (*.webp). Esse formato padrão aberto, desenvolvido pela empresa Google, oferece compactação com e sem perda para as imagens para uso na Web. As imagens WEBP sem perda são menores do que as imagens PNG, enquanto as imagens WEBP com perda são menores do que imagens JPEG. Você pode importar os arquivos WEBP como importaria qualquer outro arquivo compatível. Ao exportar um arquivo para o formato WEBP, você poderá escolher entre várias predefinições de acordo com as suas necessidades ou criar uma nova predefinição e salvá-la para uso futuro. Configurações avançadas, como qualidade e taxa de compactação, oferecem flexibilidade e controle sobre o fator de compactação para canais RGB e a proporção entre velocidade de codificação, tamanho do arquivo e qualidade, respectivamente. A transparência da imagem é mantida tanto na importação quanto na exportação.

Novo! Cortar a arte pelos limites da página na exportação

Agora, ao exportar arquivos para os formatos PNG, JPEG, GIF e WEBP, você pode cortar a sua arte pelos limites da página de desenho para remover objetos indesejados e reduzir o tamanho do arquivo.

Interface do usuário atualizada no Windows 11

Para um melhor alinhamento com a interface do usuário atualizada no Windows 11, esta atualização apresenta cantos arredondados na janela do aplicativo e nas caixas de diálogo, sombras nas caixas de diálogo, uma nova barra de título do aplicativo e layouts de alinhamento.

Aprimorado! Janela de encaixe Exportar

Esta atualização inclui uma série de recursos e melhorias na janela de encaixe Exportar para melhorar seu fluxo de trabalho. Agora, é possível exportar ativos e páginas para três outros formatos: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG) e AutoCAD Drawing Interchange Format (DXF). Para sua conveniência, os ativos e as páginas podem ser renomeados diretamente na janela de encaixe Exportar. Além disso, o botão Exportar fica acinzentado quando não há itens selecionados.

Novo! Ferramentas de dimensionamento

Com o CorelDRAW e o Corel DESIGNER, é fácil dimensionar uma parte de um objeto ou de uma imagem para um tamanho específico. A ferramenta Dimensionar parte que economiza tempo permite redimensionar uma parte de um objeto para ajustá-lo à dimensão desejada. Por exemplo, se você precisar que uma porta tenha dois metros de altura, basta especificar esse valor e arrastar verticalmente ao longo da porta para dimensioná-la. Você também pode usar a ferramenta interativa Ajustar à referência, que oferece maior precisão ao redimensionar um objeto para ajustá-lo a outro objeto. Por exemplo, essa nova ferramenta útil permite dimensionar e mover simultaneamente um parafuso para encaixá-lo perfeitamente em uma porca específica.

Novo! Visualização de hotspots CGM

O Corel DESIGNER introduz um novo botão Mostrar/ocultar Hotspots CGM para ajudar você a determinar instantaneamente quais objetos contêm dados de objetos CGM. Uma alternância rápida exibirá os hotspots com uma hachura azul distinta, eliminando um processo trabalhoso de verificar os objetos um por um para identificar os hotspots CGM. Isso é particularmente conveniente para trabalhar com conteúdo S1000D que inclui dados de objetos CGM interativos.

Novo! Adições de macro e API

Uma nova macro e uma API (setCGMregion) incluídas no Corel DESIGNER ajudam os usuários a adicionar dados de objetos rapidamente a fim de definir objetos para atender às especificações CGM. A combinação da macro e da API oferece flexibilidade ao permitir que os usuários alterem a funcionalidade da macro de acordo com as suas necessidades.

Novo! Limpar dados de objetos de grupos aninhados

Ao trabalhar com elementos e grupos de elementos que contêm metadados no Corel DESIGNER, agora você tem a opção de limpar dados de um único objeto ou de todo o grupo. Isso é útil na troca de arquivos ou designs parciais que contêm metadados confidenciais que você não deseja compartilhar.

Desempenho e estabilidade

A Atualização de setembro de 2022 do CorelDRAW Technical Suite (v24.2) também inclui correções de desempenho e estabilidade para vários problemas relatados por nossos usuários.

  • Quando você desfaz o agrupamento de objetos, a ordem de empilhamento deles na janela de encaixe Objetos é mantida conforme o esperado.
  • Quando você imprime em uma impressora PostScript independente de dispositivo, o nome do documento agora aparece na caixa Nome do arquivo da caixa de diálogo Imprimir para arquivo.
  • Agora, as propriedades de fonte e de formatação do texto em arquivos PDF importados são mantidas, independentemente das configurações de fonte e de formatação usadas para colar e importar texto de formatos de arquivo de texto.
  • Colar uma imagem do Corel PHOTO-PAINT em um documento do CorelDRAW ou do Corel DESIGNER usando o comando Editar > Colar especial e escolhendo Imagem do Corel PHOTO-PAINT 2022 agora funciona conforme o esperado.
  • As ferramentas e os menus em branco, duplicados ou que não funcionam foram removidos da área de trabalho do Adobe Illustrator no CorelDRAW.
  • Ao procurar modelos na guia Modelos da caixa de diálogo Criar um novo documento, se inserir uma consulta de busca que não retorne nenhum resultado, você poderá apagar os termos de busca sem pressionar Enter. Feche a caixa de diálogo e, na próxima vez que você abri-la, a lista de modelos disponíveis aparecerá conforme o esperado.
  • Agora, o aplicativo lembra do último modelo selecionado na guia Modelos da caixa de diálogo Criar um novo documento quando você fecha e abre a caixa de diálogo novamente durante a mesma sessão de trabalho.
  • Ao selecionar um modelo na guia Modelos da caixa de diálogo Criar um novo documento e, depois, inserir uma consulta de busca e pressionar Enter, a caixa de diálogo não fechará mais.
  • Depois que você reiniciar o aplicativo em um idioma diferente e responder à pesquisa sobre perfil do usuário, os recursos de aprendizagem recomendados não incluirão mais tópicos da ajuda do produto por padrão.
  • Renomear um modelo na guia Modelos da caixa de diálogo Criar um novo documento e, em seguida, alterar o tamanho das miniaturas, passar o mouse sobre uma miniatura ou alternar entre os modelos não resulta mais na exibição incorreta do novo nome do arquivo.
  • Quando você renomear, classificar ou filtrar modelos, alternar para a guia Configurações do documento e, depois, voltar para a guia Modelos da caixa de diálogo Criar um novo documento, agora a ordem de classificação dos modelos será mantida.
  • Depois que você excluir um ativo ou um modelo que foi marcado como favorito ou alterar a localização dele, o item não aparecerá mais quando você classificar ou filtrar itens na janela de encaixe Ativos ou na guia Modelos da caixa de diálogo Criar um novo documento.
  • Agora, o comando de menu Vincular (Objeto > Vincular) foi removido do menu Objeto e de outros elementos da interface do usuário no aplicativo, uma vez que pertence à funcionalidade OLE desatualizada, que não é mais compatível.
  • Quando você exporta vários documentos como um arquivo PDF único, a posição dos símbolos é mantida.
  • A qualidade dos bitmaps é mantida quando você abre e salva novamente arquivos SVG com bitmaps.
  • A transparência dos bitmaps é mantida durante a exportação de arquivos para o formato SVG.
  • A importação e a exportação cíclicas de arquivos EPS com preenchimentos de padrão de 2 cores não faz mais com que o CorelDRAW ou o Corel DESIGNER pare de responder.
  • Aumentar ou diminuir a largura de um objeto depois de aplicar perspectiva agora funciona conforme o esperado.
  • Quando você trabalha com a ferramenta Círculo do raio central do Corel DESIGNER, o valor na caixa de listagem Círculo do raio central na barra de propriedades é atualizado corretamente à medida que você altera a escala do desenho ou a resolução de pixels do documento.
  • O número máximo de caracteres que você pode inserir agora para o nome ou a descrição de um símbolo é 255.
  • As legendas não são mais corrompidas quando você importa um arquivo com legendas para um documento que já contém legendas.
  • Para garantir a consistência em um documento, os cantos com esquadria agora funcionam de forma idêntica tanto em legendas de vários segmentos quanto em linhas com halos.
  • Ao usar a numeração incremental no texto de legenda no Corel DESIGNER, agora você pode especificar um Valor inicial maior que 100.
  • Os artefatos visuais não aparecem mais quando você dimensiona ou move as legendas formatadas com conjuntos de estilos no Corel DESIGNER.
  • Agora os halos aparecem no lugar correto após a aplicação de estilos às legendas.
  • Os hotspots agora aparecem na posição correta após você mover ou dimensionar objetos com hotspots e, depois, exportá-los para CGM.
  • As coordenadas de hotspots são atualizadas corretamente à medida que você move uma legenda ou altera sua forma no Corel DESIGNER.
  • Os problemas na exportação de arquivos com metadados XVL para o formato CGM no Corel DESIGNER foram resolvidos.
  • Os hotspots não aparecem mais na linha do cabeçalho e no texto da legenda no Corel DESIGNER.
  • Os problemas na exportação de texto para XLIFF 2.0 no Corel DESIGNER foram resolvidos.
  • O Corel DESIGNER agora exibe uma visualização dinâmica quando você ativa a opção Ajustar à caixa na guia Escala e espelho da janela de encaixe Transformar e arrasta o mouse para especificar uma área retangular na qual dimensionar um objeto selecionado.
  • No Corel DESIGNER, quando você ativa a opção Ajustar à caixa na guia Escala e espelho da janela de encaixe Transformar para especificar uma área retangular na qual dimensionar um objeto selecionado, os botões Espelhar horizontalmente e Espelhar verticalmente ficam acinzentados por padrão.
  • No Corel DESIGNER, os valores nas caixas L ou A na guia Tamanho da janela de encaixe Transformar não são mais atualizados quando você desativa a opção Proporcional, clica no botão Definir dimensões de modo interativo ao lado de uma das caixas e, em seguida, clica no botão Definir dimensões de modo interativo ao lado da outra caixa.
  • As ações de ativar a opção Proporcional na guia Tamanho da janela de encaixe Transformar, definir a largura de forma interativa e, em seguida, definir a altura de forma interativa agora funcionam conforme o esperado.

Atualização 1

Recursos novos e melhorados

Disponível exclusivamente para assinantes e licenciados com a Manutenção CorelSure ativa, a Atualização 1 do CorelDRAW Technical Suite 2022 (v24.1) oferece melhorias em várias áreas do CorelDRAW e do Corel DESIGNER:

  • Acesse conteúdo didático personalizado com base em sua pesquisa de perfil na Tela de boas-vindas (Ajuda > Bem-vindo > Tutoriais).
  • Renomeie um ativo ou uma página na janela de encaixe Exportar clicando no rótulo do nome e inserindo um novo nome.
  • Envie comentários ou sugestões sobre o CorelDRAW Technical Suite por meio de um portal on-line clicando em Help > Submit Ideas and Feedback (Ajuda > Enviar ideias e feedback). O portal está disponível apenas em inglês. Você pode personalizar o comando de menu Submit Ideas and Feedback (Enviar ideias e feedback) e salvar as alterações em um espaço de trabalho personalizado.
  • Quando não houver correspondências exatas para a consulta de busca na guia Explorar da janela de encaixe Aprender, uma mensagem notificará que o aplicativo mostrará resultados para palavras ou caracteres semelhantes.
  • Quando você busca comandos de menu na guia Explorar da janela de encaixe Aprender, agora os resultados da busca incluem uma lista de todos os locais relevantes para acessar os comandos.
  • Agora, quando você busca comandos de menu na guia Explorar da janela de encaixe Aprender, a barra de menus aparece antes da barra do menu contextual na lista de locais para acessar os comandos.
  • Quando você busca comandos de menu na guia Explorar da janela de encaixe Aprender, agora os resultados da busca incluem o caminho completo de acesso aos comandos.
  • Preenchimento foi adicionado a ambos os lados do texto na última página da pesquisa de perfil no CorelDRAW e no Corel PHOTO-PAINT para melhorar o layout.
  • Na última página da pesquisa de personalização, uma mensagem notifica que o aplicativo está atualizando a lista de recursos de aprendizagem recomendados com base em seu perfil.

Desempenho e estabilidade

A Atualização 1 do CorelDRAW Technical Suite 2022 (v24.1) também inclui correções de desempenho e estabilidade para vários problemas relatados por nossos usuários.

  • Quando você ativa a opção Página na guia Avançado da caixa de diálogo Exportar EPS, salva um arquivo no formato EPS e o abre no Corel PHOTO-PAINT, agora o documento tem o tamanho de página correto.
  • Ao fazer uma captura de tela usando o atalho de teclado Win+SHIFT+S no Windows 10 e no Windows 11, agora você pode colar o conteúdo da Área de transferência em um documento do CorelDRAW.
  • As curvas que têm transparência com um modo de mesclagem (como 'Se mais escuro') aplicado não são mais convertidas em bitmap quando você exporta um documento para o formato EPS.
  • A remoção de artefatos da compactação JPEG agora funciona como esperado.
  • A propriedade UsePageBoundingBox foi adicionada à classe PDFVBASettings e o script de configurações do tamanho de página de exportação de PDF (Configurações de PDF > Geral) agora funciona corretamente.
  • Ao definir propriedades de contorno usando scripts VBA, o CorelDRAW altera a largura do contorno como esperado.
  • Foram resolvidos os problemas de desempenho e estabilidade com o zoom e o enquadramento ao mover objetos.
  • As ferramentas que não funcionam e outros comandos desnecessários foram removidos da caixa de ferramentas da área de trabalho do Adobe Illustrator no CorelDRAW.
  • Agora, o CorelDRAW lembra da paleta de cores PANTONE® escolhida na caixa de diálogo Opções (Ferramentas > Opções > Cor) de uma sessão para outra.
  • A inserção de caracteres especiais, como / e %, no campo de busca da guia Explorar da janela de encaixe Aprender não resulta mais em um erro de página não encontrada.
  • Quando você usa o aplicativo em turco, holandês ou sueco, a janela de encaixe Aprender agora exibe uma lista de recursos de aprendizagem em inglês.
  • Quando você clica com o botão direito do mouse na guia Explorar da janela de encaixe Aprender, o menu de contexto não fica mais disponível por padrão.
  • Os resultados da busca na guia Explorar da janela de encaixe Aprender não desaparecem mais no seguinte caso: com a guia Explorar ativa, altere o tema, alterne para a guia Dicas e, depois, volte para a guia Explorar.
  • Os usuários corporativos do CorelDRAW Technical Suite que efetuarem login no CorelDRAW.app com sua conta corel.com ou com sua conta corporativa do Microsoft 365 e abrirem um arquivo do CorelDRAW (CDR) salvo na nuvem agora poderão acessar o painel de projeto como esperado.
  • Ao realizar uma busca na guia Explorar da janela de encaixe Aprender e os resultados da busca corresponderem exatamente à consulta de busca, você não verá mais uma mensagem de erro informando que nenhuma correspondência exata foi encontrada se rolar para baixo até o final da lista e, em seguida, rolar de volta para o início da lista.
  • O aplicativo não exibe mais resultados incorretos da busca na guia Explorar da janela de encaixe Aprender quando você limpa a busca ou escolhe outro filtro enquanto os resultados da busca ainda estão sendo carregados.
  • Os problemas com legendas ocultas não traduzidas foram resolvidos nos vídeos de dicas listados na guia Explorar da janela de encaixe Aprender.
  • Agora você pode abrir um arquivo do CorelDRAW (CDR), do Corel DESIGNER (DES) ou do Corel PHOTO-PAINT (CPT) clicando duas vezes no arquivo ou clicando com o botão direito do mouse no arquivo no Explorador de Arquivos, clicando em Abrir com e escolhendo CorelDRAW, Corel DESIGNER ou Corel PHOTO-PAINT, respectivamente.
  • A aplicação de sombreamentos, envelopes ou perspectivas a bitmaps que são grupos vinculados agora está desabilitada. Para aplicar sombreamentos, envelopes ou perspectivas a bitmaps que são grupos vinculados, primeiro você deve agrupar os bitmaps com os efeitos.