Aktualizace sady CorelDRAW Graphics Suite pro předplatitele (Windows a Mac) – poznámky k verzi

Nové a vylepšené funkce

Aktualizace sady CorelDRAW Graphics Suite pro březen 2023 (v24.3), která je k dispozici výhradně pro předplatitele a držitele licencí s aktivním programem CorelSure Maintenance, přináší nové funkce a vylepšení aplikací v několika oblastech:

Novinka! Online šablony

Nyní můžete zahájit projekt z online šablony na kartě Šablony dialogového okna Vytvořit nový dokument. Nová online knihovna vám umožní okamžitý přístup k většímu počtu šablon než dřív. Vyplňte profilový dotazník, abyste mohli filtrovat šablony a zobrazit si ty, které jsou pro vás nejvhodnější.

Vylepšení! Doporučení cvičných projektů

Na poslední stránce profilového dotazníku máte nyní přístup k cvičným projektům, které odpovídají vaší úrovni dovedností a vašim potřebám a zájmům.

Vylepšení! Ovládací prvky pro vytváření dokumentů

Nově můžete nastavit omezení pro přesah na kartě Nastavení dokumentu dialogového okna Vytvořit nový dokument. Toto nastavení se uloží spolu s předvolbami dokumentu a nabízí větší flexibilitu při vytváření nových dokumentů v aplikaci CorelDRAW.

Vylepšení! Miniatury předvoleb dokumentů

Vylepšené miniatury předvoleb v dialogovém okně Vytvořit nový dokument usnadňují prohlížení a procházení širokého výběru předvoleb pro tisk, web, konkrétní zařízení a sociální sítě, které jsou v aplikaci k dispozici. Informace o velikosti stránky byly zjednodušeny, aby se zvýšila přehlednost. Ikony nyní lépe označují typ stránky a pomohou vám rychle najít přesnou předvolbu, kterou potřebujete.

Novinka! Nástroj pro variabilní obrysy

Nástroj pro variabilní obrysy umožňuje vytvářet obrysy objektů různých šířek. Můžete určit, kde začíná a končí odchylka šířky, a vytvořit tak dynamické, organicky vypadající čáry a tvary. Kromě toho můžete obrys upravit, aniž byste ovlivnili vlastnosti variabilního obrysu.

Vylepšení! Nahlašování selhání

Pokud se aplikace sady CorelDRAW Graphics Suite neočekávaně ukončí, zobrazí se při dalším spuštění dialogové okno s chybovým hlášením. Pokud nyní nechcete odesílat hlášení o chybě, můžete dialogové okno hlášení o selhání zakázat v nastavení Globální > Soukromí.

Výkon a stabilita

Aktualizace sady CorelDRAW Graphics Suite pro březen 2023 (v24.3) také zahrnuje vylepšení výkonu a stability pro několik problémů nahlášených zákazníky.

  • Aplikace CorelDRAW si nyní pamatuje nastavení oříznutí na stránku při exportu a hodnoty Transformace v dialogových oknech Export.
  • V systému Windows si aplikace CorelDRAW pamatuje nastavení v dialogovém okně Tisk.
  • Když je nástroj Malířské techniky aktivní a na panelu vlastností kliknete na tlačítko Štětec nebo Rozprašovač, v seznamu Kategorie se nyní zobrazí správné kategorie.
  • V aplikaci Corel PHOTO-PAINT se textové objekty po spojení textových objektů s pozadím a zrušení této akce zobrazí podle očekávání.
  • Byly vyřešeny problémy s výkonem textových objektů obsahujících rastrové vzorové výplně.
  • Při publikování do PDF pomocí předvolby Archivace (RGB) (Soubor > Publikovat ve formátu PDF > Předvolba PDF) se nyní správně exportují barvy.
  • V aplikaci CorelDRAW ve Windows byly vyřešeny problémy s výkonem při používání různých nástrojů myší s povolenou možností Real-Time Stylus (Nástroje > Možnosti > CorelDRAW > Nastavení pera).
  • Byly vyřešeny problémy s výkonem při úpravách odstavcového textu s odrážkami.
  • Byly vyřešeny problémy s výkonem a stabilitou při otevírání a importu souborů obsahujících symboly.
  • Nástroj Barevné kapátko na ukotvitelných panelech ve Windows nyní funguje podle očekávání.
  • Bylo vyřešeno několik problémů, kvůli kterým aplikace přestávaly reagovat.

Aktualizace zabezpečení sady CorelDRAW Graphics Suite 2022 (v24.2.1) obsahuje opravy ohrožení zabezpečení nahlášených iniciativou Zero Day Initiative (ZDI).

  • ZDI-22-1468 – GIF File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability
  • ZDI-22-1469 – BMP File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability
  • ZDI-22-1470 – JP2 File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability
  • ZDI-22-1471 – CGM File Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability
  • ZDI-22-1472 – GIF File Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability
  • ZDI-22-1473 – PDF File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability
  • ZDI-22-1474 – EMF File Parsing Out-Of-Bounds Read Remote Code Execution Vulnerability
  • ZDI-22-1475 – PCX File Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability
  • ZDI-22-1476 – PCX File Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability

Nové a vylepšené funkce

Aktualizace sady CorelDRAW Graphics Suite pro září 2022 (v24.2), která je k dispozici výhradně pro předplatitele a držitele licencí s aktivním programem CorelSure Maintenance, přináší nové funkce a vylepšení aplikací CorelDRAW a Corel PHOTO-PAINT v několika oblastech:

Nové a vylepšené funkce! Dialogové okna Nový dokument

Dialogové okno Vytvořit nový dokument bylo přepracováno tak, aby poskytovalo centrální místo pro vytváření nových výkresů. Toto dialogové okno má nyní dvě karty, Nastavení dokumentu a Šablony, a umožňuje snadno přepínat mezi jednotlivými zobrazeními.

Na kartě Nastavení dokumentu (Soubor > Nový) můžete zahájit práci s prázdným výkresem zadáním nastavení dokumentu nebo výběrem předvolby. CorelDRAW umožňuje prohledávat a procházet široký výběr předvoleb pro tisk, web, konkrétní zařízení a sociální média. Předvolby zahrnují předdefinovaná nastavení velikosti a orientace stránky, primárního režimu barev, měrných jednotek a rozlišení. Například předvolba Úvodní fotka pro LinkedIn z kategorie Sociální média používá pixely místo palců, orientaci na šířku, barvu RGB a rozměry požadované pro úvodní fotku na LinkedIn. Pro snadnější vyhledávání předvoleb umožňuje aplikace CorelDRAW filtrovat podle kategorie a typu stránky a řadit předvolby podle názvu, data a velikosti stránky.

Na kartě Šablony (Soubor > Nový ze šablony) můžete zahájit kreslení ze šablony. Rozhraní pro filtrování a řadění šablon a přístup k místním a síťovým složkám jsou přeorganizované tak, abyste rychleji našli potřebné šablony.

Novinka! Praktické projekty

Praktické projekty jsou kolekce souborů aplikací CorelDRAW (CDR) a Corel PHOTO-PAINT (CPT), které si můžete stáhnout a využít pro výuku, školení nebo ukázky. Tyto nové výukové kurzy uvnitř aplikace můžete využít k procvičení základních konceptů a zdokonalení svých dovedností. Kromě dokončené verze projektu, kterou si můžete prohlédnout jako referenci, je ke každému výukovému kurzu přiložena částečně dokončená verze obohacená o podrobné pokyny, které vám poskytnou možnosti interaktivní práce a pomohou vám projekt úspěšně dokončit. K praktickým projektům můžete přistupovat (a procházet je) prostřednictvím karty Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS). Po vyplnění profilového dotazníku uživatele získáte doporučení pro praktické projekty, které odpovídají vaší úrovni dovedností a vašim potřebám.

Novinka! Podpora pro formát souborů Google Web Picture (*.webp)

CorelDRAW a Corel PHOTO-PAINT nově nabízejí podporu pro formát souborů Google Web Picture (*.webp). Tento otevřený standardní formát vyvinutý společností Google poskytuje bezeztrátovou i ztrátovou kompresi pro obrázky určené k použití na webu. Bezeztrátové obrázky WEBP jsou menší než PNG a ztrátové obrázky WEBP jsou menší než obrázky JPEG. Soubory WEBP můžete importovat stejně jako jiné podporované soubory. Při exportu souboru do formátu WEBP si můžete vybrat z několika předvoleb podle svých potřeb nebo vytvořit novou předvolbu a uložit ji pro budoucí použití. Rozšířená nastavení, jako je kvalita a kompresní poměr, zajišťují flexibilitu a kontrolu nad kompresním faktorem pro kanály RGB a poměrem mezi rychlostí kódování, velikostí souboru a kvalitou. Průhlednost obrázků je zachována při importu i exportu.

Novinka! Oříznutí díla podle okrajů stránky při exportu

Nyní můžete při exportu souborů do formátů PNG, JPEG, GIF a WEBP oříznout dílo podle okrajů stránky a odstranit tak nežádoucí objekty a zmenšit velikost souboru.

Aktualizované uživatelské rozhraní v systému Windows 11

Pro lepší sladění s aktualizovaným uživatelským rozhraním systému Windows 11 obsahuje tato aktualizace zaoblené rohy aplikačních a dialogových oken, stíny dialogových oken, nový záhlaví okna aplikací a rozvržení.

Vylepšení! Ukotvitelný panel Export (Windows) nebo inspektor Export (macOS)

Tato aktualizace přináší řadu funkcí a vylepšení ukotvitelného panelu Export (Windows) a inspektoru Export (macOS) pro zlepšení pracovních postupů. Jednotlivé prostředky a stránky lze nyní exportovat do tří dalších formátů: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG) a AutoCAD Drawing Interchange Format (DXF). Pro vaše pohodlí lze prostředky a stránky přejmenovat přímo v ukotvitelném panelu Export (Windows) nebo inspektoru Export (macOS). Navíc je tlačítko Export zobrazené šedě, pokud nejsou vybrány žádné položky.

Novinka! Nástroje pro změnu velikosti

Aplikace CorelDRAW umožňuje snadno změnit měřítko části objektu nebo obrázku na určitou velikost. Časově úsporný nástroj Měřítko části umožňuje změnit velikost části objektu tak, aby odpovídala požadovanému rozměru. Pokud například potřebujete, aby dveře byly vysoké dva metry, jednoduše zadáte tuto hodnotu a poté přetáhnete myší podél dveří. Jejich velikost se požadovaným způsobem změní. Můžete také použít interaktivní nástroj Přizpůsobit podle referencí, který nabízí větší přesnost při změně velikosti objektu tak, aby se vešel do jiného objektu. Tento nový šikovný nástroj vám například umožní současně měřit měřítko a posouvat šroub tak, aby dokonale zapadl do konkrétní matice.

Výkon a stabilita

Aktualizace sady CorelDRAW Graphics Suite pro září 2022 (v24.2) také zahrnuje vylepšení výkonu a stability pro několik problémů nahlášených zákazníky.

  • Pokud zrušíte seskupení objektů, jejich pořadí v ukotvitelném panelu Objekty nebo inspektoru Objekty (macOS) zůstane zachované podle očekávání.
  • Při tisku na PostScriptové tiskárně nezávislé na zařízení se nyní název dokumentu zobrazí v poli Název souboru (Windows) nebo Uložit jako (macOS) dialogového okna Tisk do souboru.
  • Vlastnosti písma a formátování textu v importovaných souborech PDF jsou nyní zachovány bez ohledu na nastavení písma a formátování pro vkládání a import textu z formátů textových souborů.
  • Vkládání obrázku aplikace Corel PHOTO-PAINT do dokumentu aplikace CorelDRAW pomocí příkazu Úpravy > Vložit jinak a výběru možnosti Obrázek Corel PHOTO-PAINT 2022 nyní funguje podle návrhu.
  • Z pracovního prostoru aplikace Adobe Illustrator v aplikaci CorelDRAW v systému Windows byly odebrány prázdné, duplicitní nebo nefunkční nabídky a nástroje.
  • V systému macOS už aplikace CorelDRAW nepřestává reagovat při ukončení aplikace po exportu dokumentu do formátu DXF.
  • V systému macOS se nyní popisky grafiky na kartě Rady v inspektoru Učení zobrazují v tmavém režimu bíle.
  • V systému macOS funguje aplikace podle očekávání, pokud výrazy zadané do vyhledávacího pole na kartě Šablony dialogového okna Vytvořit nový dokument (CorelDRAW) a inspektor Prostředky obsahují následující speciální znaky: závorky (), závorky [], závorky {} a +.
  • Pokud při vyhledávání šablon na kartě Šablony v dialogovém okně Vytvořit nový dokument v systému Windows zadáte vyhledávací dotaz, který nevrátí žádné výsledky, můžete vyhledávací výrazy vymazat bez stisknutí klávesy Enter. Pokud toto dialogové okno zavřete, při jeho příštím otevření se zobrazí seznam dostupných šablon podle očekávání.
  • Aplikace si nyní pamatuje poslední vybranou šablonu na kartě Šablony dialogového okna Vytvořit nový dokument, pokud dialogové okno zavřete a znovu otevřete během stejné pracovní relace.
  • Pokud při výběru šablony na kartě Šablony v dialogovém okně Vytvořit nový dokument v systému Windows zadáte vyhledávací dotaz a stisknete klávesu Enter, toto dialogové okno se již nezavře.
  • Po opětovném spuštění aplikace v jiném jazyce a vyplnění profilového dotazníku uživatele již doporučené výukové zdroje záměrně neobsahují témata z produktové nápovědy.
  • Přejmenování šablony na kartě Šablony dialogového okna Vytvořit nový dokument a následná změna velikosti miniatur, najetí na miniaturu nebo přepnutí mezi šablonami již nevede k nesprávnému zobrazení nového názvu souboru.
  • Při přejmenování, řazení nebo filtrování šablon, následném přepnutí na kartu Nastavení dokumentu a následném přepnutí zpět na kartu Šablony dialogového okna Vytvořit nový dokument v systému Windows se nyní zachovává pořadí řazení šablon.
  • Po odstranění aktiva nebo šablony, která byla označena jako oblíbená, nebo po změně jejího umístění se příslušná položka již nezobrazuje při řazení nebo filtrování položek na ukotvitelném panelu Prostředky (Windows), inspektoru Prostředky (macOS) nebo na kartě Šablony dialogového okna Vytvořit nový dokument.
  • Příkaz nabídky Propojit (Objekt > Propojit) je nyní odstraněn z nabídky Objekt a dalších prvků uživatelského rozhraní aplikace, protože souvisí se zastaralou funkcí OLE, která se už nepodporuje.
  • Při otevírání a opětovném ukládání souborů SVG s rastry je zachována kvalita rastrů.
  • Při exportu více dokumentů do jednoho souboru PDF v systému Windows je zachována pozice symbolů.
  • Při exportu souborů do formátu SVG je zachována průhlednost rastrů.
  • Maximální počet znaků, které lze nyní zadat pro název nebo popis symbolu, je 255.
  • Když povolíte možnost Měřítko části na kartě Velikost ukotvitelného panelu Transformace (Windows) nebo inspektoru Transformace (macOS) v aplikaci CorelDRAW, bude čára omezena podle očekávání. Pro nastavení měřítka stačí podržet klávesu Ctrl a potáhnout podél objektu.
  • V systému macOS se nyní správně zobrazují názvy delší než 26 znaků, které zadáte do pole Název v dialogovém okně Vytvořit nový symbol v systému macOS (Objekt > Symbol > Vytvořit nový symbol).
  • Při importu souboru s odkazovacími čarami do dokumentu, který již odkazovací čáry obsahuje, již nedochází k jejich poškození.
  • Import a následný export souborů EPS s dvoubarevnými vzorovými výplněmi již nezpůsobuje, že by aplikace CorelDRAW v systému Windows přestala reagovat.
  • Zvětšení nebo zmenšení šířky objektu po použití perspektivy nyní funguje podle očekávání.

Nové a vylepšené funkce

Verze CorelDRAW Graphics Suite 2022 Update 1 (v24.1), která je k dispozici výhradně pro předplatitele a držitele licencí s aktivním programem CorelSure Maintenance, přináší vylepšení CorelDRAW v několika oblastech:

  • Je k dispozici přístup k personalizovanému výukovému obsahu na základě profilového dotazníku na úvodní obrazovce (Nápověda > Vítejte > Kurzy).
  • Prvek nebo stránku na ukotvitelném panelu Export (Windows) nebo inspektoru Export (macOS) je možné přejmenovat kliknutím na popisek názvu a zadáním nového názvu.
  • Zasílání připomínek nebo návrhů týkajících se sady CorelDRAW Graphics Suite je možné prostřednictvím online portálu kliknutím na Nápověda > Nápady a zpětná vazba ve Windows. Portál je k dispozici pouze v angličtině. Ve Windows můžete příkaz nabídky Nápady a zpětná vazba a uložit změny do vlastního pracovního prostoru.
  • Pokud se aplikace během relace v systému macOS neočekávaně ukončí, protokol o chybě se automaticky odešle společnosti Corel, která pomůže problém vyřešit a aplikaci vylepšit.
  • Na poslední stránce profilového dotazníku bylo pro zlepšení rozvržení na obě strany textu přidáno odsazení.
  • Pokud pro váš vyhledávací dotaz na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) nejsou k dispozici žádné přesné shody, upozorní vás zpráva, že aplikace místo toho zobrazí výsledky pro podobná slova nebo znaky.
  • Při hledání příkazů nabídky na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) teď výsledky hledání obsahují seznam všech relevantních míst pro přístup k příkazům.
  • Při hledání příkazů nabídky na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) se teď v seznamu míst pro přístup k příkazům zobrazuje panel nabídek před kontextovým panelem nabídek.
  • Při hledání příkazů nabídky na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) teď výsledky hledání zahrnují kompletní cestu k příkazům.
  • Na poslední stránce personalizačního dotazníku vás zpráva upozorní, že aplikace aktualizuje seznam doporučených výukových materiálů na základě vašeho profilu.

Výkon a stabilita

Verze CorelDRAW Graphics Suite 2022 Update 1 (v24.1) také zahrnuje vylepšení výkonu a stability pro několik problémů nahlášených zákazníky.

  • Pokud povolíte možnost Stránka na kartě Rozšířené v dialogovém okně Export EPS, uložíte soubor ve formátu EPS a potom ho otevřete v aplikaci Corel PHOTO-PAINT, bude teď dokument mít správnou velikost stránky.
  • Při pořizování snímku obrazovky pomocí klávesové zkratky Win+SHIFT+S v systémech Windows 10 a Windows 11 můžete nyní obsah schránky vložit do dokumentu CorelDRAW.
  • Křivky, které mají průhlednost s použitým režimem sloučení (například „Pokud je tmavší“), se už při exportu dokumentu do formátu EPS v systému Windows nerastrují.
  • Odstranění artefaktů s kompresí JPEG nyní funguje podle očekávání.
  • Do třídy PDFVBASettings byla přidána vlastnost UsePageBoundingBox a skriptování pro nastavení Export PDF – Velikost stránky (Nastavení PDF > Obecné) teď funguje správně.
  • Při nastavování vlastností obrysu pomocí skriptů VBA v systému Windows změní aplikace CorelDRAW šířku obrysu podle očekávání.
  • Byly vyřešeny problémy s výkonem a stabilitou přibližování a oddalování při přesouvání objektů.
  • Ze sady nástrojů v pracovním prostoru aplikace Adobe Illustrator v systému Windows byly odstraněny nefunkční nástroje a další nepotřebné příkazy.
  • CorelDRAW si nyní mezi jednotlivými relacemi pamatuje paletu barev PANTONE® zvolenou v dialogovém okně Předvolby (nabídka CorelDRAW > Předvolby > Barva v systému macOS) nebo Možnosti (Nástroje > Možnosti > Barva v systému Windows).
  • Zadání speciálních znaků, jako jsou / a %, do vyhledávacího pole na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) už nemá za následek chybu Stránka nebyla nalezena.
  • Byly vyřešeny problémy se vzhledem zaoblených rohů profilového dotazníku v systému macOS.
  • Při použití aplikace v turečtině, holandštině a švédštině ukotvitelný panel Učení (Windows) nebo inspektor Učení (macOS) nově zobrazuje seznam výukových materiálů v angličtině.
  • Pokud kliknete pravým tlačítkem myši (Windows) nebo kliknete se stisknutou klávesou Control (macOS) na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS), kontextová nabídka již není z principu dostupná.
  • Výsledky hledání na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) se v následujícím případu už nezobrazují: s aktivní kartou Prozkoumat změníte téma, přepnete na kartu Rady a potom přepnete zpátky na kartu Prozkoumat.
  • Firemní uživatelé sady CorelDRAW Graphics Suite, kteří se do aplikace CorelDRAW.app přihlásí pomocí svého účtu corel.com nebo firemního účtu Microsoft 365 a otevřou soubor CorelDRAW (CDR) uložený v cloudu, teď mohou přistupovat k ovládacímu panelu projektu podle očekávání.
  • Pokud provedete hledání na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) a výsledky hledání se přesně shodují s vaším dotazem, nezobrazuje se už chybová zpráva, že nebyly nalezeny žádné přesné shody, pokud se posunete dolů na konec seznamu a poté se vrátíte zpět na začátek seznamu.
  • Aplikace už na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS) nezobrazuje chybné výsledky hledání, když vymažete hledání nebo vyberete jiný filtr, zatímco se výsledky hledání z vašeho dotazu stále načítají.
  • V systému macOS již aplikace nepřestane reagovat, pokud z panelu vlastností přejdete do plovoucí nabídky, zadáte hodnotu, stisknete Enter a potom stisknete Esc.
  • Problémy s nepřeloženými skrytými titulky byly vyřešeny u videí s radami, která jsou uvedena v seznamu na kartě Prozkoumat ukotvitelného panelu Učení (Windows) nebo inspektoru Učení (macOS).
  • V systému Windows teď můžete otevřít soubor ve formátu CorelDRAW (CDR), Corel DESIGNER (DES) nebo Corel PHOTO-PAINT (CPT) poklepáním na soubor nebo kliknutím pravým tlačítkem myši na soubor v Průzkumníku souborů, kliknutím na příkaz Otevřít s a výběrem možnosti CorelDRAW, resp. Corel PHOTO-PAINT.
  • Použití vrženého stínu, obálky nebo perspektivy na rastry, které jsou propojenými skupinami, je nyní zakázáno. Pokud chcete použít vržený stín, obálku nebo perspektivu na rastry, které jsou propojenými skupinami, musíte nejdřív seskupit tyto rastry s příslušnými efekty.