Notes de version de la Mise à jour de CorelDRAW Graphics Suite 2022 (Windows et Mac)

Mise à jour de sécurité (15-12-2022)

La Mise à jour de sécurité de CorelDRAW Graphics Suite 2022 (v24.2.1) comprend des correctifs pour les vulnérabilités signalées par la Zero Day Initiative (ZDI).

  • ZDI-22-1468 - Vulnérabilité de divulgation d'informations en lecture hors limites dans le traitement des fichiers GIF
  • ZDI-22-1469 - Vulnérabilité de divulgation d'informations en lecture hors limites dans le traitement des fichiers BMP
  • ZDI-22-1470 - Vulnérabilité de divulgation d'informations en lecture hors limites dans le traitement des fichiers JP2
  • ZDI-22-1471 - Vulnérabilité à l'exécution de code à distance par dépassement de tampon dans l'analyse des fichiers CGM basée sur la pile
  • ZDI-22-1472 - Vulnérabilité à l'exécution de code à distance dans le traitement des fichiers GIF par écriture hors limites
  • ZDI-22-1473 - Vulnérabilité de divulgation d'informations en lecture hors limites dans le traitement des fichiers PDF
  • ZDI-22-1474 - Vulnérabilité à l'exécution de code à distance dans le traitement des fichiers EMF par lecture hors limites
  • ZDI-22-1475 - Vulnérabilité à l'exécution de code à distance dans le traitement des fichiers PCX par écriture hors limites
  • ZDI-22-1476 - Vulnérabilité à l'exécution de code à distance dans le traitement des fichiers PCX par écriture hors limites

Mise à jour de septembre 2022

Nouveautés et améliorations

Disponible exclusivement pour les abonnés et les détenteurs de licences ayant un plan de Maintenance CorelSure active, la Mise à jour de septembre 2022 de CorelDRAW Graphics Suite (v24.2) introduit de nouvelles fonctionnalités et des améliorations dans plusieurs domaines de CorelDRAW et de Corel PHOTO-PAINT :

Nouveauté et amélioration ! Boîte de dialogue Créer un nouveau document

La boîte de dialogue Créer un nouveau document repensée afin de fournir un emplacement central pour le démarrage de nouveaux dessins. Elle comporte maintenant deux onglets, Paramètres de document et Modèles, afin que vous puissiez passer d'une vue à l'autre en toute simplicité.

Dans l’onglet Paramètres de document (Fichier > Nouveau), vous pouvez commencer un dessin vierge en spécifiant les paramètres du document ou en choisissant une présélection. CorelDRAW vous permet de rechercher et de parcourir une large sélection de présélections pour l'impression, le Web, les appareils spécifiques et les réseaux sociaux. Les présélections comprennent des paramètres prédéfinis pour le format et l'orientation de la page, le mode de couleur primaire, les unités de mesure et la résolution. Par exemple, la présélection Couverture LinkedIn de la catégorie Réseaux sociaux utilise des pixels au lieu de pouces, l'orientation paysage, la couleur RGB, et a les dimensions requises pour une image de couverture LinkedIn. Pour trouver plus facilement les présélections, CorelDRAW vous permet de les filtrer par catégorie et par type de page et de les trier par nom, date et format de page.

Dans l’onglet Modèles (Fichier > Nouveau à partir d’un modèle), vous pouvez commencer un dessin à partir d’un modèle. Les interfaces permettant de filtrer et de trier les modèles ainsi que d'accéder aux dossiers locaux et réseau ont été réorganisées pour vous aider à trouver rapidement les modèles dont vous avez besoin.

Nouveau ! Projets d’entraînement

Les projets d’entraînement sont des collections de fichiers CorelDRAW (CDR) et Corel PHOTO-PAINT (CPT) que vous pouvez télécharger et utiliser aux fins d’apprentissage, de formation ou de démonstrations. Vous pouvez tirer parti de ces nouveaux didacticiels intégrés à l'application pour vous exercer aux concepts de base et affiner vos compétences. En plus de la version achevée du projet que vous pouvez consulter comme référence, chaque didacticiel est accompagné d'une version partiellement achevée, enrichie d'instructions étape par étape pour rendre l'expérience interactive et vous aider à mener à bien le projet. Vous pouvez accéder aux projets d’entraînement et les parcourir dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS). Répondez au sondage sur le profil de l'utilisateur pour obtenir des recommandations de projets d’entraînement correspondant à votre niveau de compétence et à vos besoins de conception.

Nouveau ! Prise en charge du format de fichier Google Web Picture (*.webp)

CorelDRAW et Corel PHOTO-PAINT offrent désormais la prise en charge du format de fichier Google Web Picture (*.webp). Ce format standard ouvert développé par Google fournit une compression avec et sans perte pour les images destinées à être utilisées sur le Web. La taille des images WEBP sans perte est plus petite que celle des images PNG et la taille des images WEBP avec perte est plus petite que celle des images JPEG. Vous pouvez importer des fichiers WEBP comme vous le feriez pour tout autre fichier pris en charge. Lorsque vous exportez un fichier au format WEBP, vous pouvez choisir parmi plusieurs présélections pour répondre à vos besoins ou créer une nouvelle présélection et l'enregistrer pour une utilisation ultérieure. Les paramètres avancés, tels que la qualité et le taux de compression, vous offrent la flexibilité et le contrôle du facteur de compression pour les canaux RVB et du rapport entre la vitesse d'encodage, la taille du fichier et la qualité, respectivement. La transparence des images est maintenue à l'importation et à l'exportation.

Nouveau ! Recadrage de l'œuvre aux limites de la page lors de l'exportation

Désormais, lorsque vous exportez des fichiers aux formats PNG, JPEG, GIF et WEBP, vous pouvez recadrer votre œuvre aux limites de la page de dessin pour supprimer les objets indésirables et réduire la taille du fichier.

Interface utilisateur mise à jour sous Windows 11

Pour mieux s'aligner sur l'interface utilisateur actualisée de Windows 11, cette mise à jour présente des coins arrondis sur la fenêtre de l'application et les boîtes de dialogue, des ombres sur les boîtes de dialogue, une nouvelle barre de titre de l'application et des mises en page instantanées.

Amélioration ! Menu fixe Exporter (Windows) ou inspecteur Exporter (macOS)

Cette mise à jour introduit une série de fonctionnalités et d'améliorations du menu fixe Exporter (Windows) ou de l’inspecteur Exporter (macOS) pour améliorer votre flux de travail. Les ressources et les pages peuvent désormais être exportés vers trois formats supplémentaires : Adobe Illustrator (AI), AutoCAD Drawing Database (DWG) et AutoCAD Drawing Interchange Format (DXF). Pour plus de commodité, les ressources et les pages peuvent être renommées directement dans le menu fixe Exporter (Windows) ou l’inspecteur Exporter (macOS). En outre, le bouton Exporter est grisé lorsqu'aucun élément n'est sélectionné.

Nouveau ! Outils de mise à l’échelle

CorelDRAW vous permet de mettre facilement à l'échelle une partie d'un objet ou d'une image à une taille spécifique. L'outil de mise à l'échelle d'une portion, qui permet de gagner du temps, vous permet de redimensionner une portion d'un objet pour l'adapter à la dimension souhaitée. Par exemple, si vous souhaitez qu'une porte mesure deux mètres de haut, il vous suffit de spécifier cette valeur, puis de faire glisser verticalement la porte pour la mettre à l'échelle. Vous pouvez également utiliser l'outil interactif Ajuster à la référence, qui offre une plus grande précision lors du redimensionnement d'un objet pour l'intégrer à un autre. Par exemple, ce nouvel outil pratique vous permet de mettre à l'échelle et de déplacer simultanément une vis pour qu'elle s'adapte parfaitement à un écrou spécifique.

Performances et stabilité

La Mise à jour de septembre 2022 de CorelDRAW Graphics Suite (v24.2) comprend également des corrections de performances et de stabilité pour plusieurs problèmes signalés par les clients.

  • Lorsque vous annulez le regroupement d'objets, leur ordre d'empilement dans le menu fixe Objets (Windows) ou l’inspecteur Objets (macOS) est conservé comme prévu.
  • Lorsque vous imprimez sur une imprimante PostScript indépendante du périphérique, le nom du document apparaît désormais dans le champ Nom du fichier (Windows) ou Enregistrer sous (macOS) de la boîte de dialogue Imprimer dans un fichier.
  • Les propriétés de police et de formatage du texte dans les PDF importés sont désormais conservées, quels que soient les paramètres de police et de formatage utilisés pour coller et importer du texte à partir de formats de fichiers texte.
  • Coller une image Corel PHOTO-PAINT dans un document CorelDRAW en utilisant la commande Édition > Collage spécial et en choisissant Image Corel PHOTO-PAINT 2022 fonctionne maintenant comme prévu.
  • Les menus et outils vides, en double ou non fonctionnels ont été supprimés de l'espace de travail d'Adobe Illustrator de CorelDRAW sous Windows.
  • Sous macOS, CorelDRAW ne cesse plus de répondre lorsque vous quittez l'application après avoir exporté un document au format DXF.
  • Sous macOS, les légendes des graphismes dans l’onglet Conseils de l’inspecteur Apprendre s’affichent maintenant en blanc en mode Sombre.
  • Sous macOS, l'application fonctionne comme prévu lorsque les termes que vous saisissez dans le champ de recherche de l'onglet Modèles de la boîte de dialogue Créer un document (CorelDRAW) l’inspecteur Ressources contient les caractères spéciaux suivants : parenthèses (), crochets [], accolades {} et signe +.
  • Lors de la recherche de modèles dans l’onglet Modèles de la boîte de dialogue Créer un document sous Windows, si vous saisissez une requête de recherche qui ne renvoie aucun résultat, vous pouvez effacer les termes de la recherche sans appuyer sur la touche Entée. Lorsque vous fermez la boîte de dialogue, la prochaine fois que vous l'ouvrirez, la liste des modèles disponibles apparaîtra comme prévu.
  • L'application se souvient désormais du dernier modèle sélectionné dans l’onglet Modèles de la boite de dialogue Créer un document lorsque vous fermez la boîte de dialogue et la rouvrez au cours de la même session de travail.
  • Lorsque vous sélectionnez un modèle dans l’onglet Modèles de la boite de dialogue Créer un document sous Windows, si vous entrez une requête de recherche et appuyez sur Entrée, la boite de dialogue ne se ferme plus.
  • Après avoir relancé l'application dans une autre langue et répondu au sondage sur le profil de l'utilisateur, les ressources d'apprentissage recommandées n'incluent plus les sujets de l'aide produit par conception.
  • Renommer un modèle dans l’onglet Modèles de la boîte de dialogue Créer un document, puis changer la taille des miniatures, passer la souris sur une miniature ou passer d’un modèle à un autre n'entraîne plus l'affichage incorrect du nouveau nom de fichier.
  • Lorsque vous renommez, triez ou filtrez des modèles, puis passez à l'onglet Paramètres de document et revenez ensuite dans l’onglet Modèles de la boîte de dialogue Créer un document sous Windows, l’ordre de tri des modèles est maintenant conservé.
  • Après avoir supprimé une ressource ou un modèle qui était marqué comme favori, ou après avoir modifié son emplacement, l'élément n'apparaît plus lors du tri ou du filtrage des éléments dans le menu fixe Ressources (Windows), l’inspecteur Ressources (macOS), ou dans l’onglet Modèles de la boîte de dialogue Créer un document.
  • La commande de menu Lier (Objet > Lier) est maintenant supprimée du menu Objet et des autres éléments de l’interface utilisateur dans l’application car elle appartient aux fonctionnalités OLE obsolètes, qui ne sont plus prises en charge.
  • La qualité des bitmaps est maintenue lors de l'ouverture et du réenregistrement des fichiers SVG avec bitmaps.
  • Lorsque vous exportez plusieurs documents en un seul PDF sous Windows, la position des symboles est conservée.
  • La transparence des bitmaps est maintenue lors de l'exportation des fichiers au format SVG.
  • Le nombre maximum de caractères que vous pouvez désormais saisir pour le nom ou la description d'un symbole est de 255.
  • Lorsque vous activez l’option Mise à l’échelle d’une portion dans l’onglet Taille du menu fixe Transformation (Windows) ou de l’inspecteur Transformation (macOS) dans CorelDRAW, la ligne est contrainte comme prévu. Il suffit de maintenir enfoncée la touche Ctrl et de faire glisser la souris le long d’un objet pour définir l’échelle.
  • Sous macOS, les noms qui dépassent 26 caractères s'affichent désormais correctement lorsque vous les tapez dans le champ Nom de la boite de dialogue Créer un symbole sous macOS (Objet > Symbole > Créer un symbole).
  • Les légendes ne sont plus altérées lorsque vous importez un fichier contenant des légendes dans un document qui en contient déjà.
  • L'importation et l'exportation aller-retour de fichiers EPS avec des remplissages de motifs en deux couleurs ne provoquent plus l'arrêt de la réponse de CorelDRAW sous Windows.
  • L'augmentation ou la diminution de la largeur d'un objet après l'application de la perspective fonctionne désormais comme prévu.

Update 1

Nouveautés et améliorations

Disponible exclusivement pour les abonnés et les détenteurs de licences ayant une Maintenance CorelSure active, CorelDRAW Graphics Suite 2022 Update 1 (v24.1) apporte des améliorations fonctionnelles dans de nombreux domaines :

  • Accédez à un contenu d'apprentissage personnalisé basé sur l’enquête de votre profil dans l’écran d’accueil (Aide > Bienvenue > Didacticiels).
  • Renommez une ressource ou une page via le menu fixe Exporter (Windows) ou l’inspecteur Exporter (macOS) en cliquant sur le libellé du nom et en saisissant un nouveau nom.
  • Soumettez vos commentaires ou suggestions sur CorelDRAW Graphics Suite via un portail en ligne en cliquant sur Help (Aide) > Submit Ideas and Feedback (Soumettre des idées et commentaires) sous Windows. Ce portail est disponible uniquement en anglais. Sous Windows, vous pouvez personnaliser l’option de menu Submit Ideas and Feedback (Soumettre des idées et commentaires) et enregistrer vos modifications dans un espace de travail personnalisé.
  • Si l'application se ferme inopinément pendant une session sous macOS, un rapport d'erreur est automatiquement envoyé à Corel pour aider à résoudre le problème et améliorer l'application.
  • Des espaces ont été ajoutés des deux côtés du texte sur la dernière page de l'enquête de profil pour améliorer la mise en page.
  • Lorsqu'il n'y a pas de correspondance exacte pour votre demande de recherche dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS), un message vous informe que l'application affichera des résultats pour des mots ou des caractères similaires à la place.
  • Lorsque vous recherchez des options de menu dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS), les résultats de la recherche comprennent désormais une liste de tous les emplacements pertinents pour accéder aux options.
  • À présent, lorsque vous recherchez des options de menu dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS), la barre de menus est placée avant la barre de menus contextuels dans la liste des emplacements permettant d'accéder aux options.
  • Lorsque vous recherchez des options de menu dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS), les résultats de la recherche comprennent désormais le chemin complet d’accès aux options.
  • Sur la dernière page de l'enquête de personnalisation, un message vous informe que l'application met à jour la liste des ressources d'apprentissage recommandées en fonction de votre profil.

Performance et stabilité

CorelDRAW Graphics Suite 2022 Update 1 (v24.1) comprend également des corrections de performances et de stabilité pour plusieurs problèmes signalés par les clients.

  • Lorsque vous activez l’option Page dans l’onglet Avancé de la boite de dialogue Exportation de fichier EPS, enregistrez un fichier au format EPS, puis ouvrez-le dans Corel PHOTO-PAINT. Le document a désormais le format de page correct.
  • Lorsque vous effectuez une capture d'écran à l'aide du raccourci clavier Win+MAJ+S sous Windows 10 et Windows 11, vous pouvez désormais coller le contenu du Presse-papiers dans un document CorelDRAW.
  • Les courbes auxquelles est appliquée une transparence avec un mode de fusion (tel que « Si plus sombre ») ne sont plus tramées lorsque vous exportez un document au format EPS sous Windows.
  • La suppression des artefacts de compression JPEG fonctionne maintenant comme prévu.
  • La propriété UsePageBoundingBox a été ajoutée à la classe PDFVBASettings et le scriptage des paramètres de format de page d’exportation au format PDF (Paramètres PDF > Général) fonctionne maintenant normalement.
  • Lors de la définition des propriétés de contour à l'aide de scripts VBA sous Windows, CorelDRAW modifie la largeur du contour comme prévu.
  • Les problèmes de performance et de stabilité liés au zoom et au panoramique lors du déplacement d'objets ont été résolus.
  • Les outils non fonctionnels et les autres commandes inutiles ont été supprimés de la boîte à outils de l'espace de travail d'Adobe Illustrator sous Windows.
  • CorelDRAW mémorise maintenant la palette de couleurs PANTONE® que vous choisissez dans les Préférences (menu CorelDRAW > Préférences > Couleur sous macOS) ou dans la boîte de dialogue Options (Outils > Options > Couleur sous Windows) d’une session à une autre.
  • La saisie de caractères spéciaux, tels que / et %, dans le champ de recherche de l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS) ne donne plus lieu à une erreur « Page introuvable ».
  • Les problèmes liés à l'apparition des coins arrondis de l'enquête de profil sous macOS ont été résolus.
  • Lorsque vous utilisez l'application en turc, néerlandais et suédois, le menu fixe Apprendre (Windows) ou l’inspecteur Apprendre (macOS) affiche désormais une liste de ressources d'apprentissage en anglais.
  • Lorsque vous cliquez avec le bouton droit de la souris (Windows) ou que vous cliquez avec la touche Contrôle dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS), le menu contextuel n'est plus disponible par défaut.
  • Les résultats de recherche dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS) ne disparaissent plus dans le cas suivant : avec l’onglet Explorer actif, lorsque vous changez le thème, basculez vers l’onglet Conseils, puis revenez dans l’onglet Explorer.
  • Les utilisateurs professionnels de CorelDRAW Graphics Suite qui se connectent à CorelDRAW.app en utilisant leur compte corel.com ou leur compte professionnel Microsoft 365 et qui ouvrent un fichier CorelDRAW (CDR) enregistré dans le Cloud peuvent maintenant accéder au tableau de bord du projet comme prévu.
  • Lorsque vous lancez une recherche dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS) et lorsque les résultats de la recherche correspondent exactement à votre demande, vous ne verrez plus le message d'erreur indiquant qu'aucune correspondance exacte n'a été trouvée si vous faites défiler la liste jusqu'à la fin, puis revenez en haut de la liste.
  • L'application n'affiche plus de résultats de recherche erronés dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS) lorsque vous effacez la recherche ou choisissez un autre filtre alors que les résultats de votre demande sont toujours en cours de chargement.
  • Sous macOS, l'application ne cesse plus de répondre si vous accédez à un menu contextuel à partir de la barre de propriétés, saisissez une valeur, appuyez sur Entrée, puis sur Échap.
  • Les problèmes liés aux sous-titres non traduits ont été résolus pour les vidéos de conseils qui sont répertoriées dans l’onglet Explorer du menu fixe Apprendre (Windows) ou de l’inspecteur Apprendre (macOS).
  • Sous Windows, vous pouvez maintenant ouvrir un fichier CorelDRAW (CDR), Corel DESIGNER (DES) ou Corel PHOTO-PAINT (CPT) en double-cliquant sur ce fichier ou en cliquant avec le bouton droit de la souris dans l’Explorateur de fichiers, puis en cliquant sur Ouvrir avec et en choisissant CorelDRAW ou Corel PHOTO-PAINT, respectivement.
  • L'application d'une ombre portée, d'une enveloppe ou d'une perspective aux bitmaps qui sont des groupes liés est désormais désactivée. Pour appliquer une ombre portée, une enveloppe ou une perspective à des images bitmap qui sont des groupes liés, vous devez d'abord regrouper les images bitmap avec les effets.