Aktualizacja pakietu CorelDRAW Graphics Suite 2022 (Windows i Mac) — informacje o wersji

Aktualizacja zabezpieczeń (2022-12-15)

Aktualizacja zabezpieczeń pakietu CorelDRAW Graphics Suite 2022 (wer. 24.2.1) zawiera poprawki usuwające luki zgłoszone przez organizację Zero Day Initiative (ZDI).

  • ZDI-22-1468 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku GIF
  • ZDI-22-1469 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku BMP
  • ZDI-22-1470 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku JP2
  • ZDI-22-1471 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku przepełnienia bufora opartego na stosie podczas analizowania pliku CGM
  • ZDI-22-1472 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku zapisu poza granicami podczas analizowania pliku GIF
  • ZDI-22-1473 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku PDF
  • ZDI-22-1474 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku odczytu poza granicami podczas analizowania pliku EMF
  • ZDI-22-1475 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku zapisu poza granicami podczas analizowania pliku PCX
  • ZDI-22-1476 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku zapisu poza granicami podczas analizowania pliku PCX

Aktualizacja na wrzesień 2022 r.

Nowe i ulepszone funkcje

Dostępna wyłącznie dla subskrybentów i posiadaczy licencji z aktywnym programem serwisowania CorelSure Aktualizacja pakietu CorelDRAW Graphics Suite na wrzesień 2022 r. (v24.2) zapewnia nowe funkcje i ulepszenia w kilku obszarach programów CorelDRAW i Corel PHOTO-PAINT:

Nowość i ulepszenie! Okno dialogowe Utwórz nowy dokument

Okno dialogowe Utwórz nowy dokument zostało przeprojektowane, aby stać się centralnym miejscem rozpoczynania pracy nad nowymi rysunkami. Okno dialogowe ma teraz dwie karty, Ustawienia dokumentu oraz Szablony, więc można z łatwością przełączać między nimi.

Na karcie Ustawienia dokumentu (Plik > Nowy) możesz rozpocząć pusty rysunek, określając ustawienia dokumentu lub wybierając wzorzec. Program CorelDRAW pozwala wyszukiwać i przeglądać szeroki wybór wzorców przeznaczonych do druku, publikacji w Internecie, na określonym urządzeniu lub w mediach społecznościowych. Wzorce zawierają ustawienia wstępne rozmiaru i orientacji strony, podstawowy tryb kolorów, jednostki miary i rozdzielczość. Na przykład wzorzec przeznaczony do stron tytułowych na LinkedIn z kategorii mediów społecznościowych korzysta z pomiaru w pikselach zamiast cali, a także z orientacji poziomej, trybu koloru RGB oraz ma wymiary wymagane dla grafiki prezentacyjnej w serwisie LinkedIn. Aby łatwiej znajdować wzorce, program CorelDRAW pozwala je filtrować według kategorii i typu strony oraz sortować według nazwy, daty i rozmiaru strony.

Na karcie Szablony (Plik > Nowy z szablonu) możesz zacząć rysunek na podstawie szablonu. Interfejsy filtrowania i sortowania szablonów oraz dostępu do folderów lokalnych i sieciowych zostały przeorganizowane, aby pomóc Ci szybko znaleźć potrzebne szablony.

Nowość! Projekty szkoleniowe

Projekty szkoleniowe to kolekcje plików programów CorelDRAW (CDR) i Corel PHOTO-PAINT (CPT), które możesz pobrać do wykorzystania w nauce, szkoleniach i prezentacjach. Możesz wykorzystać te nowe samouczki dostępne z poziomu aplikacji, aby ćwiczyć podstawowe operacje i doskonalić umiejętności. Poza finalną wersją projektu, do której możesz się odwoływać, w każdym samouczku jest też częściowo ukończona wersja, wzbogacona o instrukcje krok po kroku, dzięki którym proces nauki jest interakcyjny i łatwiej jest z sukcesem sfinalizować projekt. Masz dostęp do projektów szkoleniowych i możesz przeglądać je na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS). Wypełnij ankietę profilu użytkownika, aby uzyskać propozycje projektów szkoleniowych, które odpowiadają Twoim umiejętnościom i potrzebom projektowym.

Nowość! Obsługa formatu plików Google Web Picture (*.webp)

Programy CorelDRAW i Corel PHOTO-PAINT oferują już obsługę formatu plików Google Web Picture (*.webp). Ten otwarty standard opracowany przez Google zapewnia bezstratną i stratną kompresję obrazków przeznaczonych do użycia w Internecie. Bezstratne obrazki WEBP są mniejsze niż pliki PNG, a stratne obrazki WEBP są mniejsze niż pliki JPEG. Możesz importować pliki WEBP jak każde inne obsługiwane pliki. Kiedy eksportujesz plik do formatu WEBP, możesz wybrać spośród kilku wzorców odpowiednio do potrzeb lub utworzyć nowy wzorzec i zapisać go do wykorzystania w przyszłości. Ustawienia zaawansowane, takie jak współczynnik jakości i kompresji, zapewniają elastyczność i kontrolę nad czynnikiem kompresji w przypadku kanałów RGB oraz szybkością kodowania, rozmiarem pliku i jego jakością. Przezroczystość obrazka jest utrzymywana zarówno przy imporcie, jak i eksporcie.

Nowość! Kadrowanie rysunku do granic strony przy eksporcie

Teraz, gdy eksportujesz pliki do formatów PNG, JPEG, GIF i WEBP, możesz kadrować rysunek do granic strony, aby usunąć niepotrzebne obiekty i zmniejszyć rozmiar pliku.

Unowocześniony interfejs użytkownika w systemie Windows 11

Aby lepiej dostroić program do unowocześnionego interfejsu systemu Windows 11, ta aktualizacja wprowadza zaokrąglone narożniki okna aplikacji i okien dialogowych, cienie okien dialogowych, nowy pasek tytułowy aplikacji i dopasowane układy okien.

Ulepszenie! Okno dokowane Eksportuj (Windows) lub inspektor Eksportuj (macOS)

Ta aktualizacja wprowadza kilka funkcji i ulepszeń okna dokowanego Eksportuj (Windows) oraz inspektora Eksportuj (macOS), aby usprawnić tok pracy. Zasoby i strony mogą teraz być eksportowane do trzech dodatkowych formatów: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG) oraz AutoCAD Drawing Interchange Format (DXF). Dla wygody użytkownika nazwy zasobów i stron można zmieniać bezpośrednio w oknie dokowanym Eksportuj (Windows) lub inspektorze Eksportuj (macOS). Ponadto przycisk Eksportuj jest wyszarzony, jeżeli nie wybrano żadnych elementów.

Nowość! Narzędzia do skalowania

Program CorelDRAW umożliwia łatwe skalowanie części obiektu lub obrazka do określonego rozmiaru. Narzędzie skalowania częściowego pozwala na zmianę rozmiaru części obiektu, aby dopasować go do wymaganych wymiarów, nie tracąc czasu. Na przykład jeżeli potrzebujesz drzwi wysokich na dwa metry, wystarczy że określisz tę wartość, a następnie przeciągniesz wskaźnik pionowo wzdłuż drzwi, aby zastosować do nich skalowanie. Możesz także użyć interakcyjnego narzędzia dopasowania do odniesienia, które oferuje większą dokładność przy zmianie rozmiaru obiektu w celu wpasowania go w inny obiekt. To nowe poręczne narzędzie pozwala na przykład jednocześnie skalować i przenosić śrubę tak, aby dopasować ją dokładnie do określonej nakrętki.

Wydajność i stabilność

Aktualizacja pakietu CorelDRAW Graphics Suite na wrzesień 2022 r. (v24.2) zawiera również poprawki wydajności i stabilności wynikłe z kilku problemów zgłoszonych przez klientów.

  • Po rozdzieleniu grupy obiektów ich kolejność ułożenia w oknie dokowanym Obiekty (Windows) lub inspektorze Obiekty (macOS) zostaje zachowana.
  • Przy drukowaniu do drukarki postscriptowej niezależnej od urządzenia nazwa dokumentu jest wyświetlana w polu Nazwa pliku (Windows) lub Zapisz jako (macOS) okna dialogowego Drukuj do pliku.
  • Właściwości czcionki i formatowania tekstu w importowanych plikach PDF są teraz zachowywane niezależnie od ustawień czcionki i formatowania dla wklejania i importowania tekstu z tekstowych formatów plików.
  • Wklejanie obrazka z programu Corel PHOTO-PAINT do dokumentu programu CorelDRAW przy użyciu polecenia Edycja > Wklej specjalne i wybraniu opcji obrazka Corel PHOTO-PAINT 2022 teraz działa tak, jak powinno.
  • Puste, zduplikowane lub niefunkcjonalne elementy menu i narzędzia zostały usunięte z obszaru roboczego Adobe Illustrator w programie CorelDRAW dla Windows.
  • W systemie macOS program CorelDRAW nie przestaje już odpowiadać po opuszczeniu aplikacji po wyeksportowaniu dokumentu do formatu DXF.
  • W systemie macOS podpisy grafik na karcie Podpowiedzi inspektora Dowiedz się teraz są białe w trybie ciemnym.
  • W systemie macOS aplikacja działa zgodnie z oczekiwaniami po wprowadzeniu w polu wyszukiwania na karcie Szablony okna dialogowego Utwórz nowy dokument (CorelDRAW) i inspektora Zasoby terminów zawierających następujące znaki specjalne: nawiasy okrągłe (), nawiasy kwadratowe [], nawiasy klamrowe {} oraz +.
  • Przy wyszukiwaniu szablonów na karcie Szablony okna dialogowego Utwórz nowy dokument w systemie Windows po wprowadzeniu zapytania, które nie da żadnych wyników, można wyczyścić terminy wyszukiwania bez naciskania klawisza Enter. Po zamknięciu okna dialogowego i jego następnym otwarciu lista dostępnych szablonów pojawi się tak, jak powinna.
  • Po zamknięciu okna dialogowego i ponownym jego otwarciu w tej samej sesji aplikacja pamięta już ostatni wybrany szablon na karcie Szablony okna dialogowego Utwórz nowy dokument.
  • Po wybraniu szablonu na karcie Szablony okna dialogowego Utwórz nowy dokument w systemie Windows, jeżeli wprowadzi się wyszukiwane zapytanie i naciśnie klawisz Enter, okno dialogowe już się niepotrzebnie nie zamyka.
  • Po ponownym uruchomieniu aplikacji w innej wersji językowej i wypełnieniu ankiety profilu użytkownika, zalecane materiały do nauki nie zawierają już domyślnie tematów z pomocy produktu.
  • Zmiana nazwy szablonu na karcie Szablony okna dialogowego Utwórz nowy dokument, a następnie zmiana rozmiaru miniatur, najechanie wskaźnikiem na miniaturę lub przełączenie między szablonami nie skutkuje już nieprawidłowym wyświetlaniem nowej nazwy pliku.
  • Po zmianie nazw, sortowaniu lub filtrowaniu szablonów, a następnie przełączeniu na kartę Ustawienia dokumentu i ponownym przełączeniu na kartę Szablony okna dialogowego Utwórz nowy dokument w systemie Windows porządek sortowania szablonów jest już zachowywany.
  • Po usunięciu zasobu lub szablonu oznaczonego jako ulubiony lub zmianie jego lokalizacji element ten nie pojawi się już podczas sortowania lub filtrowania elementów w oknie dokowanym Zasoby (Windows), inspektorze Zasoby (macOS) lub na karcie Szablony okna dialogowego Utwórz nowy dokument.
  • Polecenie Łącze (Obiekt > Łącze) zostało usunięte z menu Obiekt i innych elementów interfejsu użytkownika w aplikacji, ponieważ odnosiło się do przestarzałej funkcji OLE, która nie jest już obsługiwana.
  • Jakość map bitowych jest zachowywana przy otwieraniu i ponownym zapisywaniu plików SVG z mapami bitowymi.
  • Przy eksportowaniu wielu dokumentów jako jednego pliku PDF w systemie Windows ułożenie symboli jest zachowywane.
  • Przezroczystość w mapach bitowych jest zachowywana przy eksportowaniu plików do formatu SVG.
  • Maksymalna liczba znaków, które możesz obecnie wprowadzić jako nazwę lub opis symbolu, to 255.
  • Po włączeniu opcji skalowania częściowego na karcie Rozmiar okna dokowanego Transformuj (Windows) lub inspektora Transformuj (macOS) w programie CorelDRAW linia jest ograniczana tak, jak powinna. Aby ustawić skalę, wystarczy przytrzymać klawisz Ctrl i przeciągnąć wskaźnik wzdłuż obiektu.
  • W systemie macOS nazwy dłuższe niż 26 znaków wyświetlają się już prawidłowo podczas wpisywania w polu Nazwa okna dialogowego Utwórz nowy symbol w systemie macOS (Obiekt > Symbol > Utwórz nowy symbol).
  • Objaśnienia nie ulegają uszkodzeniu po zaimportowaniu pliku z objaśnieniami do dokumentu, który już je zawiera.
  • Importowanie i eksportowanie plików EPS z wypełnieniami deseniem dwukolorowym nie powoduje już wstrzymania pracy programu CorelDRAW w systemie Windows.
  • Zwiększanie lub zmniejszanie szerokości obiektu po zastosowaniu perspektywy działa już tak, jak powinno.

Aktualizacja 1

Nowe i ulepszone funkcje

Dostępna wyłącznie dla subskrybentów i posiadaczy licencji z aktywnym programem serwisowania CorelSure Aktualizacja 1 pakietu CorelDRAW Graphics Suite 2022 (v24.1) wprowadza usprawnienia w kilku obszarach programu CorelDRAW:

  • Uzyskaj dostęp do spersonalizowanych materiałów edukacyjnych na podstawie ankiety profilowej na ekranie powitalnym (Pomoc > Witamy > Samouczki).
  • Zmieniaj nazwę zasobu lub strony w oknie dokowanym Eksportuj (Windows) lub inspektorze Eksportuj (macOS), klikając etykietę nazwy i wpisując nową nazwę.
  • Przesyłaj komentarze lub sugestie dotyczące pakietu CorelDRAW Graphics Suite przez portal internetowy, klikając Pomoc > Prześlij pomysły i opinie w systemie Windows. Portal jest dostępny tylko w języku angielskim. W systemie Windows można dostosować polecenie menu Prześlij pomysły i opinie i zapisać zmiany w niestandardowym obszarze roboczym.
  • Jeśli nastąpi nieoczekiwane zamknięcie aplikacji podczas sesji w systemie macOS, raport dziennika błędów jest automatycznie wysyłany do firmy Corel, aby pomóc w rozwiązaniu problemu i udoskonaleniu aplikacji.
  • Po obu stronach tekstu na ostatniej stronie ankiety profilowej dodano odstępy, aby poprawić wygląd.
  • W przypadku braku dokładnych wyników dla zapytania wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS) otrzymasz powiadomienie, że aplikacja pokaże wyniki dla podobnych słów lub znaków.
  • Podczas wyszukiwania poleceń menu na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS) wyniki wyszukiwania teraz zawierają listę wszystkich odpowiednich lokalizacji, w których dostępne są polecenia.
  • Teraz kiedy szukasz poleceń menu na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS), pasek menu jest wymieniony przed paskiem menu kontekstowego na liście lokalizacji z dostępem do poleceń.
  • Podczas wyszukiwania poleceń menu na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS) wyniki wyszukiwania teraz zawierają pełną ścieżkę do poleceń.
  • Na ostatniej stronie ankiety personalizacji pojawia się powiadomienie o aktualizacji listy zasobów edukacyjnych polecanych na podstawie profilu użytkownika.

Wydajność i stabilność

Aktualizacja 1 pakietu CorelDRAW Graphics Suite 2022 (v24.1) zawiera również poprawki wydajności i stabilności w zakresie kilku problemów zgłoszonych przez klientów.

  • Kiedy włączysz opcję Strona na karcie Zaawansowane w oknie dialogowym Eksportuj do formatu EPS, zapiszesz plik w formacie EPS, a następnie otworzysz go w programie Corel PHOTO-PAINT, dokument będzie już miał właściwy rozmiar strony.
  • Przy robieniu zrzutów ekranu skrótem klawiaturowym Win+Shift+S w systemach Windows 10 i Windows 11 możesz teraz wkleić zawartość Schowka do dokumentu programu CorelDRAW.
  • Krzywe mające przezroczystość z zastosowanym trybem scalania (takim jak „Jeśli ciemniejszy”) nie są już rasteryzowane podczas eksportowania dokumentu do formatu EPS w systemie Windows.
  • Usuwanie artefaktów kompresji JPEG działa już tak, jak powinno.
  • Właściwość UsePageBoundingBox została dodana do klasy PDFVBASettings, a skryptowanie ustawień dla opcji Rozmiar strony eksportu PDF (Ustawienia PDF > Ogólne) teraz działa prawidłowo.
  • Podczas ustawiania właściwości konturu przy użyciu skryptów VBA w systemie Windows program CorelDRAW zmienia szerokość konturu tak, jak powinien.
  • Rozwiązano problemy z wydajnością i stabilnością podczas powiększania i panoramowania przy przesuwaniu obiektów.
  • Niefunkcjonalne narzędzia i inne niepotrzebne polecenia zostały usunięte z przybornika w obszarze roboczym Adobe Illustrator w systemie Windows.
  • Program CorelDRAW zapamiętuje między sesjami paletę kolorów PANTONE® wybraną w oknie dialogowym Preferencje (menu CorelDRAW > Preferencje > Kolor w systemie macOS) lub Opcje (Narzędzia > Opcje > Kolor w systemie Windows)
  • Wprowadzanie znaków specjalnych, takich jak / i % w polu wyszukiwania karty Poznaj w oknie dokowanym Dowiedz się (Windows) lub inspektorze Dowiedz się (macOS) nie skutkuje już błędem „Nie znaleziono strony”.
  • Rozwiązano problemy z wyglądem zaokrąglonych narożników ankiety profilu w systemie macOS.
  • Podczas korzystania z aplikacji w języku tureckim, holenderskim i szwedzkim okno dokowane Dowiedz się (Windows) lub inspektor Dowiedz się (macOS) wyświetla już listę materiałów edukacyjnych w języku angielskim.
  • Po kliknięciu prawym przyciskiem myszy (Windows) lub kliknięciu z przytrzymanym przyciskiem Control karty Poznaj w oknie dokowanym Dowiedz się (Windows) lub inspektorze Dowiedz się (macOS) menu kontekstowe nie jest już domyślnie dostępne.
  • Wyniki wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS) nie znikają już w następującym przypadku: z aktywną kartą Poznaj zmień motyw, przełącz na kartę Podpowiedzi a następnie z powrotem na kartę Poznaj.
  • Użytkownicy korporacyjni pakietu CorelDRAW Graphics Suite, którzy logują się do aplikacji CorelDRAW.app za pomocą konta corel.com lub firmowego konta Microsoft 365 i otwierają plik CorelDRAW (CDR) zapisany w chmurze mogą teraz uzyskać dostęp do pulpitu projektu.
  • Podczas wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS), w przypadku gdy rezultaty wyszukiwania odpowiadają dokładnie zapytaniu, po przewinięciu do końca listy i powrotnym przewinięciu do góry, nie będzie już wyświetlany komunikat błędu o nieznalezieniu dokładnych dopasowań.
  • Aplikacja nie wyświetla już złych wyników wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS) po wyczyszczeniu wyszukiwania lub wybraniu innego filtru, gdy wyniki wyszukiwania dla Twojego zapytania wciąż są wczytywane.
  • W systemie macOS aplikacja nie przestaje już odpowiadać po przejściu do palety z poziomu paska właściwości, wprowadzeniu wartości, naciśnięciu Enter, a następnie Esc.
  • Rozwiązano problemy z nieprzetłumaczonymi napisami w przypadku nagrań wideo z podpowiedziami, które są wymienione na karcie Poznaj okna dokowanego Dowiedz się (Windows) lub inspektora Dowiedz się (macOS).
  • W systemie Windows teraz możesz otworzyć plik CorelDRAW (CDR), DESIGNER (DES) lub Corel PHOTO-PAINT (CPT), klikając go dwukrotnie lub klikając plik prawym przyciskiem myszy w Eksploratorze plików, klikając Otwórz za pomocą i wybierając odpowiednio program CorelDRAW lub Corel PHOTO-PAINT.
  • Stosowanie cienia, obwiedni lub perspektywy do map bitowych, które są połączonymi grupami jest już niemożliwe. Aby zastosować cień, obwiednię lub perspektywę do map bitowych, które są łączonymi grupami, musisz najpierw pogrupować mapy bitowe z efektami.