CorelDRAW Technical Suite 2022 — informacje o aktualizacji

Aktualizacja zabezpieczeń (2022-12-15)

Aktualizacja zabezpieczeń pakietu CorelDRAW Technical Suite 2022 (wer. 24.2.1) zawiera poprawki usuwające luki zgłoszone przez organizację Zero Day Initiative (ZDI).

  • ZDI-22-1468 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku GIF
  • ZDI-22-1469 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku BMP
  • ZDI-22-1470 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku JP2
  • ZDI-22-1471 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku przepełnienia bufora opartego na stosie podczas analizowania pliku CGM
  • ZDI-22-1472 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku zapisu poza granicami podczas analizowania pliku GIF
  • ZDI-22-1473 — luka w zabezpieczeniach umożliwiająca ujawnienie informacji w przypadku odczytu poza granicami podczas analizowania pliku PDF
  • ZDI-22-1474 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku odczytu poza granicami podczas analizowania pliku EMF
  • ZDI-22-1475 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku zapisu poza granicami podczas analizowania pliku PCX
  • ZDI-22-1476 — luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w przypadku zapisu poza granicami podczas analizowania pliku PCX

Aktualizacja na wrzesień 2022 r.

Nowe i ulepszone funkcje

Dostępna wyłącznie dla subskrybentów i posiadaczy licencji z aktywnym programem serwisowania CorelSure Aktualizacja pakietu CorelDRAW Technical Suite na wrzesień 2022 r. (v24.2) zapewnia nowe funkcje i ulepszenia w kilku obszarach programów Corel DESIGNER, CorelDRAW i Corel PHOTO-PAINT:

Nowość i ulepszenie! Okno dialogowe Utwórz nowy dokument

Okno dialogowe Utwórz nowy dokument zostało przeprojektowane, aby stać się centralnym miejscem rozpoczynania pracy nad nowymi rysunkami. Okno dialogowe ma teraz dwie karty, Ustawienia dokumentu oraz Szablony, więc można z łatwością zmieniać widok.

Na karcie Ustawienia dokumentu (Plik > Nowy) możesz rozpocząć pusty rysunek, określając ustawienia dokumentu lub wybierając wzorzec. Programy CorelDRAW i Corel DESIGNER pozwalają wyszukiwać i przeglądać szeroki wybór wzorców do druku, publikacji w Internecie, na określonym urządzeniu i w mediach społecznościowych. Wzorce zawierają ustawienia wstępne rozmiaru i orientacji strony, podstawowy tryb kolorów, jednostki miary i rozdzielczość. Na przykład wzorzec przeznaczony do stron tytułowych na LinkedIn z kategorii mediów społecznościowych korzysta z pomiaru w pikselach zamiast cali, a także z orientacji poziomej, trybu koloru RGB oraz ma wymiary wymagane dla grafiki prezentacyjnej w serwisie LinkedIn. Aby łatwiej znajdować wzorce, programy CorelDRAW i Corel DESIGNER pozwalają je filtrować według kategorii i typu strony oraz sortować według nazwy, daty i rozmiaru strony.

Na karcie Szablony (Plik > Nowy z szablonu) możesz zacząć rysunek na podstawie szablonu. Interfejsy filtrowania i sortowania szablonów oraz dostępu do folderów lokalnych i sieciowych zostały przeorganizowane, aby pomóc Ci szybko znaleźć potrzebne szablony.

Nowość! Projekty szkoleniowe

Projekty szkoleniowe to kolekcje plików programów CorelDRAW (CDR) i Corel PHOTO-PAINT (CPT), które możesz pobrać do wykorzystania w nauce, szkoleniach i prezentacjach. Możesz wykorzystać te nowe samouczki dostępne z poziomu aplikacji, aby ćwiczyć podstawowe operacje i doskonalić umiejętności. Poza finalną wersją projektu, do której możesz się odwoływać, w każdym samouczku jest też częściowo ukończona wersja, wzbogacona o instrukcje krok po kroku, dzięki czemu proces nauki jest interakcyjny i łatwiej jest z sukcesem sfinalizować projekt. Możesz uzyskać dostęp do projektów szkoleniowych i przeglądać je na karcie Poznaj okna dokowanego Dowiedz się. Wypełnij ankietę profilu użytkownika, aby uzyskać propozycje projektów szkoleniowych, które odpowiadają Twoim umiejętnościom i potrzebom projektowym.

Nowość! Obsługa formatu plików Google Web Picture (*.webp)

Programy CorelDRAW, Corel DESIGNER i Corel PHOTO-PAINT teraz oferują obsługę formatu plików Google Web Picture (*.webp). Ten otwarty standard opracowany przez Google zapewnia bezstratną i stratną kompresję obrazków przeznaczonych do użycia w Internecie. Bezstratne obrazki WEBP są mniejsze niż pliki PNG, a stratne obrazki WEBP są mniejsze niż pliki JPEG. Możesz importować pliki WEBP jak każde inne obsługiwane pliki. Kiedy eksportujesz plik do formatu WEBP, możesz wybrać spośród kilku wzorców odpowiednio do potrzeb lub utworzyć nowy wzorzec i zapisać go do wykorzystania w przyszłości. Ustawienia zaawansowane, takie jak współczynnik jakości i kompresji, zapewniają elastyczność i kontrolę nad czynnikiem kompresji w przypadku kanałów RGB oraz szybkością kodowania, rozmiarem pliku i jego jakością. Przezroczystość obrazka jest utrzymywana zarówno przy imporcie, jak i eksporcie.

Nowość! Kadrowanie rysunku do granic strony przy eksporcie

Teraz, gdy eksportujesz pliki do formatów PNG, JPEG, GIF i WEBP, możesz kadrować rysunek do granic strony, aby usunąć niepotrzebne obiekty i zmniejszyć rozmiar pliku.

Unowocześniony interfejs użytkownika w systemie Windows 11

Aby lepiej dostroić program do unowocześnionego interfejsu systemu Windows 11, ta aktualizacja wprowadza zaokrąglone narożniki okna aplikacji i okien dialogowych, cienie okien dialogowych, nowy pasek tytułowy aplikacji i dopasowane układy okien.

Ulepszenie! Okno dokowane Eksportuj

Ta aktualizacja wprowadza szereg funkcji i ulepszeń okna dokowanego Eksportuj, aby usprawnić tok pracy. Zasoby i strony mogą teraz być eksportowane do trzech dodatkowych formatów: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG) oraz AutoCAD Drawing Interchange Format (DXF). Dla wygody użytkownika nazwy zasobów i stron można zmieniać bezpośrednio w oknie dokowanym Eksportuj. Ponadto przycisk Eksportuj jest wyszarzony, jeżeli nie wybrano żadnych elementów.

Nowość! Narzędzia do skalowania

Programy CorelDRAW i Corel DESIGNER umożliwiają łatwe skalowanie części obiektu lub obrazka do określonego rozmiaru. Narzędzie skalowania częściowego pozwala na zmianę rozmiaru części obiektu, aby dopasować go do wymaganych wymiarów, nie tracąc czasu. Na przykład jeżeli potrzebujesz drzwi wysokich na dwa metry, wystarczy że określisz tę wartość, a następnie przeciągniesz wskaźnik pionowo wzdłuż drzwi, aby zastosować do nich skalowanie. Możesz także użyć interakcyjnego narzędzia dopasowania do odniesienia, które oferuje większą dokładność przy zmianie rozmiaru obiektu w celu wpasowania go w inny obiekt. To nowe poręczne narzędzie pozwala na przykład jednocześnie skalować i przenosić śrubę tak, aby dopasować ją dokładnie do określonej nakrętki.

Nowość! Podgląd obszarów aktywnych CGM

Program Corel DESIGNER wprowadza nowy przycisk Pokaż/ukryj obszary aktywne CGM, który pomoże błyskawicznie określić, które obiekty zawierają dane obiektu CGM. Szybkie przełączenie go spowoduje wyświetlenie obszarów aktywnych z charakterystycznym niebieskim kreskowaniem, eliminując konieczność żmudnego przeglądania obiektów jednego po drugim w celu znalezienia obszarów aktywnych CGM. Jest to szczególnie wygodne w przypadku pracy z materiałami zgodnymi ze specyfikacją S1000D, zawierającymi interaktywne dane obiektu CGM.

Nowość! Dodatki makro i API

Nowe makro i API (setCGMregion) udostępniane przez Corel DESIGNER pomagają użytkownikom szybko dodawać dane obiektów, aby definiować obiekty spełniające specyfikacje CGM. Kombinacja makra i API oferuje elastyczność, gdyż pozwala użytkownikom zmieniać funkcjonalność makra stosownie do potrzeb.

Nowość! Czyszczenie danych obiektu z zagnieżdżonych grup

Przy pracy z elementami i grupami elementów, które zawierają metadane w programie Corel DESIGNER, użytkownicy mogą już czyścić dane pojedynczego obiektu lub całej grupy. Jest to przydatne, gdy zachodzi konieczność wymieniania się plikami lub fragmentami projektów, które zawierają wrażliwe metadane, których nie chcemy udostępnić.

Wydajność i stabilność

Aktualizacja pakietu CorelDRAW Technical Suite na wrzesień 2022 r. (v24.2) zawiera również poprawki wydajności i stabilności wynikłe z kilku problemów zgłoszonych przez klientów.

  • Po rozdzieleniu grupy obiektów ich kolejność ułożenia w oknie dokowanym Obiekty zostaje zachowana.
  • Przy drukowaniu do drukarki postscriptowej niezależnej od urządzenia nazwa dokumentu jest wyświetlana w polu Nazwa pliku okna dialogowego Drukuj do pliku.
  • Właściwości czcionki i formatowania tekstu w importowanych plikach PDF są teraz zachowywane niezależnie od ustawień czcionki i formatowania dla wklejania i importowania tekstu z tekstowych formatów plików.
  • Wklejanie obrazka z programu Corel PHOTO-PAINT do dokumentu programu CorelDRAW lub Corel DESIGNER przy użyciu polecenia Edycja > Wklej specjalne i wybraniu opcji obrazka Corel PHOTO-PAINT 2022 teraz działa tak, jak powinno.
  • Puste, zduplikowane lub niefunkcjonalne elementy menu i narzędzia zostały usunięte z obszaru roboczego Adobe Illustrator w programie CorelDRAW.
  • Przy wyszukiwaniu szablonów na karcie Szablony okna dialogowego Utwórz nowy dokument po wprowadzeniu zapytania, które nie da żadnych wyników, można wyczyścić wyszukiwane terminy bez naciskania klawisza Enter. Po zamknięciu okna dialogowego i jego następnym otwarciu lista dostępnych szablonów pojawi się tak, jak powinna.
  • Aplikacja teraz pamięta ostatni wybrany szablon na karcie Szablony okna dialogowego Utwórz nowy dokument po zamknięciu okna dialogowego i ponownym jego otwarciu w tej samej sesji.
  • Po wybraniu szablonu na karcie Szablony okna dialogowego Utwórz nowy dokument, jeżeli wprowadzi się wyszukiwane zapytanie i naciśnie klawisz Enter, okno dialogowe już się niepotrzebnie nie zamyka.
  • Po ponownym uruchomieniu aplikacji w innej wersji językowej i wypełnieniu ankiety profilu użytkownika, zalecane materiały do nauki nie zawierają już domyślnie tematów z pomocy produktu.
  • Zmiana nazwy szablonu na karcie Szablony okna dialogowego Utwórz nowy dokument, a następnie zmiana rozmiaru miniatur, najechanie kursorem na miniaturę lub przełączenie między szablonami nie skutkuje już nieprawidłowym wyświetlaniem nowej nazwy pliku.
  • Po zmianie nazw, sortowaniu lub filtrowaniu szablonów, a następnie przełączeniu na kartę Ustawienia dokumentu i ponownym przełączeniu na kartę Szablony okna dialogowego Utwórz nowy dokument porządek sortowania szablonów jest już zachowywany.
  • Po usunięciu zasobu lub szablonu oznaczonego jako ulubiony lub zmianie jego lokalizacji element ten nie pojawi się już podczas sortowania lub filtrowania elementów w oknie dokowanym Zasoby lub na karcie Szablony okna dialogowego Utwórz nowy dokument.
  • Polecenie menu Łącze (Obiekt > Łącze) zostało usunięte z menu Obiekt i innych elementów interfejsu użytkownika w aplikacji, ponieważ odnosiło się do przestarzałej funkcji OLE, która nie jest już obsługiwana.
  • Przy eksportowaniu wielu dokumentów jako jednego pliku PDF ułożenie symboli jest zachowywane.
  • Jakość map bitowych jest zachowywana przy otwieraniu i ponownym zapisywaniu plików SVG z mapami bitowymi.
  • Przezroczystość w mapach bitowych jest zachowywana przy eksportowaniu plików do formatu SVG.
  • Importowanie i eksportowanie plików EPS z wypełnieniami deseniem dwukolorowym nie powoduje już wstrzymania pracy programu CorelDRAW ani Corel DESIGNER.
  • Zwiększanie lub zmniejszanie szerokości obiektu po zastosowaniu perspektywy teraz działa tak, jak powinno.
  • Gdy pracujesz z narzędziem Okrąg metodą środek-promień w programie Corel DESIGNER, wartość na liście Okrąg metodą środek-promień na pasku właściwości jest prawidłowo aktualizowana w miarę, jak zmieniana jest w dokumencie skala rysowania lub rozdzielczość w pikselach.
  • Maksymalna liczba znaków, które możesz obecnie wprowadzić jako nazwę lub opis symbolu, to 255.
  • Objaśnienia nie ulegają uszkodzeniu po zaimportowaniu pliku z objaśnieniami do dokumentu, który już je zawiera.
  • Aby zapewnić spójność w dokumencie, ostre narożniki zachowują się obecnie tak samo zarówno w wieloczłonowych objaśnieniach, jak i w liniach z halo.
  • Przy korzystaniu z numerowania przyrostowego w tekstach objaśnień można określić wartość początkową większą niż 100.
  • W trakcie skalowania lub przesuwania objaśnień sformatowanych z użyciem zestawów stylów w programie Corel DESIGNER nie występują już wizualne artefakty.
  • Po zastosowaniu stylów do objaśnień halo pojawiają się już w prawidłowym położeniu.
  • Obszary aktywne wyświetlają się w prawidłowym położeniu po przesunięciu lub przeskalowaniu obiektów, które zawierają obszary aktywne, a następnie po wyeksportowaniu ich do formatu CGM.
  • Współrzędne obszarów aktywnych są już prawidłowo uaktualnianie przy przesuwaniu objaśnienia lub zmianie jego kształtu w programie Corel DESIGNER.
  • Rozwiązano problemy z eksportowaniem plików z metadanymi XVL do formatu CGM w programie Corel DESIGNER.
  • Obszary aktywne nie pojawiają się już zarówno na linii wiodącej, jak i tekście objaśnienia w programie Corel DESIGNER.
  • Wyliminowano problemy z eksportowaniem tekstu do formatu XLIFF 2.0 w programie Corel DESIGNER.
  • Corel DESIGNER już wyświetla dynamiczny podgląd, jeśli włączona zostanie opcja Dopasuj do pola na karcie Skala i odbicie lustrzane okna dokowanego Transformuj i przeciągnięciem określamy prostokątny obszar, do którego chcemy przeskalować zaznaczony obiekt.
  • W programie Corel DESIGNER, gdy włączona zostanie opcja Dopasuj do pola na karcie Skala i odbicie lustrzane okna dokowanego Transformuj, przy określaniu prostokątnego obszaru, do którego chcemy przeskalować zaznaczony obiekt, przyciski Odbicie lustrzane w poziomie i Odbicie lustrzane w pionie są celowo wyszarzone.
  • W programie Corel DESIGNER wartości w polach szerokości lub wysokości na karcie Rozmiar okna dokowanego Transformuj nie są już dłużej aktualizowane, jeżeli wyłączysz opcję Proporcjonalnie, klikniesz umieszczony przy jednym z pól przycisk Ustaw wymiary interakcyjnie, a następnie klikniesz przycisk Ustaw wymiary interakcyjnie umieszczony przy drugim polu.
  • Włączenie opcji Proporcjonalnie na karcie Rozmiar okna dokowanego Transformuj powoduje, że interakcyjne ustawianie szerokości a następnie interakcyjne ustawianie wysokości działa już tak, jak powinno.

Aktualizacja 1

Nowe i ulepszone funkcje

Dostępna jedynie dla subskrybentów i posiadaczy licencji z aktywnym programem serwisowania CorelSure Aktualizacja 1 pakietu CorelDRAW Technical Suite 2022 (v24.1) wprowadza usprawnienia w kilku obszarach programów CorelDRAW i Corel DESIGNER:

  • Uzyskaj dostęp do spersonalizowanych materiałów edukacyjnych na podstawie ankiety profilowej na ekranie powitalnym (Pomoc > Witamy > Samouczki).
  • Zmieniaj nazwę zasobu lub strony w oknie dokowanym Eksportuj, klikając etykietę nazwy i wpisując nową nazwę.
  • Przesyłaj komentarze lub sugestie dotyczące pakietu CorelDRAW Technical Suite przez portal internetowy, klikając Pomoc > Prześlij pomysły i opinie. Portal jest dostępny tylko w języku angielskim. Możesz dostosować polecenie menu Prześlij pomysły i opinie i zachować zmiany w niestandardowym obszarze roboczym.
  • W przypadku braku dokładnych wyników dla zapytania wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się otrzymasz powiadomienie, że aplikacja pokaże wyniki dla podobnych słów lub znaków.
  • Podczas wyszukiwania poleceń menu na karcie Poznaj okna dokowanego Dowiedz się wyniki wyszukiwania teraz zawierają listę wszystkich odpowiednich lokalizacji, w których dostępne są polecenia.
  • Teraz kiedy szukasz poleceń menu na karcie Poznaj okna dokowanego Dowiedz się, pasek menu jest wymieniony przed paskiem menu kontekstowego na liście lokalizacji z dostępem do poleceń.
  • Podczas wyszukiwania poleceń menu na karcie Poznaj okna dokowanego Dowiedz się wyniki wyszukiwania zawierają już pełną ścieżkę do poleceń.
  • Po obu stronach tekstu na ostatniej stronie ankiety profilowej w programach CorelDRAW i Corel PHOTO-PAINT dodano odstępy, aby poprawić wygląd.
  • Na ostatniej stronie ankiety personalizacji pojawia się powiadomienie o aktualizacji listy zasobów edukacyjnych polecanych na podstawie profilu użytkownika.

Wydajność i stabilność

Aktualizacja 1 pakietu CorelDRAW Technical Suite 2022 (v24.1) zawiera również poprawki wydajności i stabilności w zakresie kilku problemów zgłoszonych przez klientów.

  • Kiedy włączysz opcję Strona na karcie Zaawansowane w oknie dialogowym Eksportuj do formatu EPS, zapiszesz plik w formacie EPS, a następnie otworzysz go w programie Corel PHOTO-PAINT, dokument będzie już miał właściwy rozmiar strony.
  • Przy robieniu zrzutów ekranu skrótem klawiaturowym Win+Shift+S w systemach Windows 10 i Windows 11 możesz teraz wkleić zawartość Schowka do dokumentu programu CorelDRAW.
  • Krzywe mające przezroczystość z zastosowanym trybem scalania (takim jak „Jeśli ciemniejszy”) nie są już rasteryzowane podczas eksportowania dokumentu do formatu EPS.
  • Usuwanie artefaktów kompresji JPEG działa już tak, jak powinno.
  • Właściwość UsePageBoundingBox została dodana do klasy PDFVBASettings, a skryptowanie ustawień opcji Rozmiar strony eksportu PDF (Ustawienia PDF > Ogólne) działa już tak, jak powinno.
  • Podczas ustawiania właściwości konturu przy użyciu skryptów VBA program CorelDRAW zmienia szerokość konturu tak, jak powinien.
  • Rozwiązano problemy z wydajnością i stabilnością podczas powiększania i panoramowania przy przesuwaniu obiektów.
  • Niefunkcjonalne narzędzia i inne niepotrzebne polecenia zostały usunięte z przybornika w obszarze roboczym Adobe Illustrator w programie CorelDRAW.
  • Program CorelDRAW teraz zapamiętuje między sesjami paletę kolorów PANTONE® wybraną w oknie dialogowym Opcje (Narzędzia > Opcje > Kolor).
  • Wprowadzanie znaków specjalnych, takich jak / i % w polu wyszukiwania karty Poznaj w oknie dokowanym Dowiedz się nie skutkuje już błędem „Nie znaleziono strony”.
  • Podczas korzystania z aplikacji w języku tureckim, holenderskim i szwedzkim okno dokowane Dowiedz się teraz wyświetla listę materiałów edukacyjnych w języku angielskim.
  • Po kliknięciu prawym przyciskiem myszy karty Poznaj okna dokowanego Dowiedz się menu kontekstowe nie jest już domyślnie dostępne.
  • Wyniki wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się nie znikają już w następującym przypadku: z aktywną kartą Poznaj zmień motyw, przełącz na kartę Podpowiedzi a następnie z powrotem na kartę Poznaj.
  • Użytkownicy korporacyjni pakietu CorelDRAW Technical Suite, którzy logują się do aplikacji CorelDRAW.app za pomocą konta corel.com lub firmowego konta Microsoft 365 i otwierają plik CorelDRAW (CDR) zapisany w chmurze mogą teraz uzyskać dostęp do pulpitu projektu.
  • Podczas wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się, w przypadku gdy rezultaty wyszukiwania odpowiadają dokładnie zapytaniu, po przewinięciu do końca listy i powrotnym przewinięciu do góry, nie będzie już wyświetlany komunikat błędu o nieznalezieniu dokładnych dopasowań.
  • Aplikacja nie wyświetla już złych wyników wyszukiwania na karcie Poznaj okna dokowanego Dowiedz się po wyczyszczeniu wyszukiwania lub wybraniu innego filtra, gdy wyniki wyszukiwania dla Twojego zapytania wciąż są wczytywane.
  • Rozwiązano problemy z nieprzetłumaczonymi napisami w przypadku nagrań wideo z podpowiedziami, które są wymienione na karcie Poznaj okna dokowanego Dowiedz się.
  • Teraz możesz otworzyć plik CorelDRAW (CDR), Corel DESIGNER (DES) lub Corel PHOTO-PAINT (CPT), klikając go dwukrotnie lub klikając plik prawym przyciskiem myszy w Eksploratorze plików, klikając Otwórz za pomocą i wybierając odpowiednio program CorelDRAW, Corel DESIGNER lub Corel PHOTO-PAINT.
  • Stosowanie cienia, obwiedni lub perspektywy do map bitowych, które są połączonymi grupami jest już niemożliwe. Aby zastosować cień, obwiednię lub perspektywę do map bitowych, które są połączonymi grupami, musisz najpierw pogrupować mapy bitowe z efektami.