CorelDRAW Technical Suite 2022 更新版本說明

安全性更新 (2022 年 12 月 15 日)

CorelDRAW Technical Suite 2022 安全性更新 (v24.2.1) 包含由零日攻擊計畫 (ZDI) 所回報的各項漏洞之修正程式。

  • ZDI-22-1468 - GIF 檔案剖析超出範圍的讀取資訊揭露漏洞
  • ZDI-22-1469 - BMP 檔案剖析超出範圍的讀取資訊揭露漏洞
  • ZDI-22-1470 - JP2 檔案剖析超出範圍的讀取資訊揭露漏洞
  • ZDI-22-1471 - CGM 檔案剖析堆疊型緩衝概覽遠端程式碼執行漏洞
  • ZDI-22-1472 - CGM 檔案剖析超出範圍寫入遠端程式碼執行漏洞
  • ZDI-22-1473 - PDF 檔案剖析超出範圍的讀取資訊揭露漏洞
  • ZDI-22-1474 - EMF 檔案剖析超出範圍讀取入遠端程式碼執行漏洞
  • ZDI-22-1475 - PCX 檔案剖析超出範圍寫入遠端程式碼執行漏洞
  • ZDI-22-1476 - PCX 檔案剖析超出範圍寫入遠端程式碼執行漏洞

2022 年 9 月更新

全新功能與增強功能

CorelDRAW Technical Suite 2022 年 9 月更新 (v24.2) 僅適用於訂閱者和目前擁有有效 CorelSure 維護服務方案的授權持有人,並在以下方面為 Corel DESIGNER、CorelDRAW 與 Corel PHOTO-PAINT 提供新功能和增強功能:

新功能以及加強功能!「建立新文件」對話方塊

「建立新文件」對話方塊經過重新設計,方便您集中在一處開始新繪圖。此對話方塊現在提供兩個標籤:「文件設定」「範本」,您可輕鬆在兩者之間切換。

「文件設定」標籤上 (「檔案」>「新增」),您可以藉由指定文件設定或選擇預設項目來開始新的空白繪圖。您可透過 CorelDRAW 和 Corel DESIGNER 搜尋和瀏覽各種列印、Web、裝置專用和社群媒體預設項目。預設項目包括頁面大小與方向、主要色彩模式、測量單位和解析度的預先定義設定。例如,「社群」類別中的 LinkedIn 封面預設項目使用像素而非英寸,並使用橫向、RGB 色彩,且具有 LinkedIn 封面圖片要求的度量。為了讓您更輕鬆尋找預設項目,CorelDRAW 和 Corel DESIGNER 提供過濾功能,您可按照類別和頁面類型過濾,並依名稱、日期和頁面大小排序。

「範本」標籤上 (「檔案」>「從範本新增」),您可以從範本開始新繪圖。過濾和排序範本的介面,以及存取本機與網路資料夾的介面均經過重新編排,可協助您快速找到需要的範本。

全新功能!練習專案

練習專案是一系列的 CorelDRAW (CDR) 和 Corel PHOTO-PAINT (CPT) 檔案,您可以下載並用來學習、訓練或示範。您可以利用這些新的應用程式內教學課程來練習基本概念,讓您的技巧更加熟練。除了提供完成的專案版本供您參考,每個教學課程也隨附部分完成的版本,並提供逐步指引,可透過互動式體驗協助您順利完成專案。您可以在「學習」泊塢視窗的「探索」標籤上存取和瀏覽練習專案。填寫使用者個人檔案問卷調查,取得符合您技術程度和設計需求的練習專案建議。

全新功能!支援 Google Web Picture (*.webp) 檔案格式

CorelDRAW、Corel DESIGNER 和 Corel PHOTO-PAINT 現在支援 Google Web Picture (*.webp) 檔案格式。這個 Google 開發的開放標準格式提供無損和有損壓縮,適用於為在網路上使用設計的影像。WEBP 無損影像小於 PNG,而 WEBP 有損影像小於 JPEG 影像。就像其他所有支援的檔案一樣,您可以匯入 WEBP 檔案。將檔案匯出為 WEBP 格式時,您可以根據需求從多個預設項目中選擇,或是建立新的預設項目並儲存以供日後使用。畫質和壓縮比等進階設定為您提供彈性,可控制 RGB 色頻的壓縮係數,以及編碼速度、檔案大小和畫質之間的比率。匯入和匯出時影像透明度都會維持原樣。

全新功能!匯出時裁切作品以符合頁面邊界

現在將檔案匯出為 PNG、JPEG、GIF 和 WEBP 格式時,您可以裁切作品以符合繪圖頁面邊界,移除不需要的物件並縮小檔案大小。

更新 Windows 11 的使用者介面

為了更融入 Windows 11 更新後的使用者介面,本更新推出圓角應用程式視窗與對話方塊、對話方塊陰影、全新的應用程式標題列以及簡潔的版面配置。

增強功能!「匯出」泊塢視窗

本更新為「匯出」泊塢視窗推出多項功能與增強功能,可改善您的工作流程。資產與頁面可匯出的格式現在額外增加三種:Adobe Illustrator (AI)、AutoCAD Drawing Database (DWG) 與 AutoCAD Drawing Interchange Format (DXF)。為方便您使用,可直接在「匯出」泊塢視窗中為資產和頁面重新命名。此外,在沒有選取任何項目的情況下,「匯出」按鈕會呈現灰色。

全新功能!縮放工具

CorelDRAW 和 Corel DESIGNER 可讓您輕鬆將物件或影像的一部分縮放為特定大小。省時的「部分縮放」工具可讓您調整物件某一部分的大小,以符合所需的度量。例如,如果您的門高度需為七英尺,只要指定該值,然後沿著門垂直拖曳即可縮放。您也可以使用提供更高精準度的「調整成參照目標」工具,將物件大小調整至剛好容納在另一個物件中。例如,這個便利的新工具可讓您同時縮放和移動螺絲,讓它完美容納在指定螺帽中。

全新功能!CGM 醒目提示預覽

Corel DESIGNER 推出全新的「顯示/隱藏 CGM 醒目提示」按鈕,協助您立即判斷哪些物件包含 CGM 物件資料。快速切換會顯示帶有顯眼藍色剖面線的醒目提示,省去逐一篩選物件來識別 CGM 醒目提示的費力程序。使用包含互動式 CGM 物件資料的 S1000D 內容時,此功能尤其方便。

全新功能!新增巨集與 API

Corel DESIGNER 隨附的新巨集與 API (setCGMregion),可協助使用者快速新增物件資料,用於定義物件以符合 CGM 規格。巨集與 API 組合提供靈活性,可讓使用者根據需求變更巨集功能。

全新功能!清除巢狀群組的物件資料

在 Corel DESIGNER 中使用可能包含中繼資料的元素和元素群組時,您現在可選擇清除單一物件或整個群組的資料。交換的檔案或部分設計若包含您不想分享的敏感中繼資料,這個功能特別有幫助。

效能與穩定度

CorelDRAW Technical Suite 2022 年 9 月更新 (v24.2) 也針對一些客戶回報的問題進行效能和穩定度修正。

  • 復原物件群組時,「物件」泊塢視窗中的堆疊順序會維持原樣。
  • 現在列印至獨立於裝置的 PostScript 印表機時,文件名稱會顯示在「列印至檔案」對話方塊的「檔案名稱」方塊中。
  • 無論貼上和匯入文字檔案格式的文字字型與格式設定為何,現在匯入的 PDF 中,文字的字型和格式屬性都會維持原樣。
  • 使用「編輯」>「選擇性貼上」指令,然後選擇「Corel PHOTO-PAINT 2022 影像」,將 Corel PHOTO-PAINT 影像貼到 CorelDRAW 或 Corel DESIGNER 文件中,這個操作現在能正常運作。
  • 我們已從 CorelDRAW 的 Adobe Illustrator 工作區中移除空白、重複或無法運作的功能表與工具。
  • 「建立新文件」對話方塊的「範本」標籤上搜尋範本時,如果您輸入的搜尋查詢沒有傳回任何結果,不需要按 Enter 即可清除搜尋字詞。關閉對話方塊,下次再開啟時可用範本清單將會正常顯示。
  • 在同一個工作階段執行期間關閉對話方塊並重新開啟時,現在應用程式會記住您上次在「建立新文件」對話方塊的「範本」標籤上選取的範本。
  • 「建立新文件」對話方塊的「範本」標籤上選取範本,然後輸入搜尋查詢並按下 Enter 時,對話方塊不會再關閉。
  • 以不同語言重新啟動應用程式,並完成使用者個人檔案問卷調查後,建議的學習資源不會再依設計包含產品說明中的主題。
  • 「建立新文件」對話方塊的「範本」標籤上重新命名範本,然後變更縮圖大小、將游標移至縮圖上方或在不同範本間切換時,不會再導致新檔名顯示錯誤。
  • 當您重新命名、排序或過濾範本,然後切換至「文件設定」標籤,再切換回「建立新文件」對話方塊的「範本」標籤時,範本的排列順序現在會維持原樣。
  • 刪除標示為「我的最愛」的資產或範本,或是變更了項目的位置後,在「資產」泊塢視窗或「建立新文件」對話方塊的「範本」標籤上排序或過濾項目時,該項目不會再顯示。
  • 現在已從「物件」功能表和應用程式中的其他使用者介面元素移除「連結」功能表指令 (「物件」>「連結」),因為此指令與不再支援的過時 OLE 功能有關。
  • 將多個文件匯出為單一 PDF 檔時,符號的位置會維持原樣。
  • 開啟並重新儲存包含點陣圖的 SVG 檔案時,點陣圖畫質會維持原樣。
  • 將檔案匯出為 SVG 格式時,點陣圖的透明度會維持原樣。
  • 來回匯入和匯出含有雙色花紋填色的 EPS 檔案,不會再導致 CorelDRAW 或 Corel DESIGNER 停止回應。
  • 現在套用透視圖後可正常增加或減少物件的寬度。
  • 在 Corel DESIGNER 中使用「中心-半徑圓形」工具時,屬性列上「中心-半徑圓形」清單方塊中的值,會隨著您變更繪圖比例或文件像素解析度正常更新。
  • 現在可為符號名稱或描述輸入的字元數上限為 255。
  • 將含有標示線的檔案匯入原來就包含標示線的文件時,標示線不會再損毀。
  • 為了確保文件一致性,現在斜接邊角在多分支標示線和含有光暈的線條中功能完全相同。
  • 在 Corel DESIGNER 中,為標示線文字使用遞增數字時,現在「開始」值可以指定為大於 100。
  • 在 Corel DESIGNER 中縮放或移動以樣式集設定格式的標示線時,不會再顯示視覺痕跡。
  • 現在對標示線套用樣式後,光暈會顯示在正確位置。
  • 現在移動或縮放含有醒目提示的物件,然後匯出為 CGM 後,醒目提示會顯示在正確位置。
  • 在 Corel DESIGNER 中,現在移動標示線或變更其形狀時,醒目提示座標會正常隨之更新。
  • 在 Corel DESIGNER 中將含有 XVL 中繼資料的檔案匯出為 CGM 格式時發生的問題已解決。
  • 在 Corel DESIGNER 中,醒目提示不會再同時顯示於指引線和標示線文字上。
  • 在 Corel DESIGNER 中將檔案匯出為 XLIFF 2.0 時發生的問題已解決。
  • 現在當您在「變形」泊塢視窗的「縮放與鏡射」標籤上啟用「符合方塊大小」選項,並拖曳指定縮放所選物件要符合的矩形區域時,Corel DESIGNER 會顯示動態預覽。
  • 在 Corel DESIGNER 中,當您在「變形」泊塢視窗的「縮放與鏡射」標籤上啟用「符合方塊大小」選項,指定縮放所選物件要符合的矩形區域時,「水平鏡射」「垂直鏡射」按鈕會依設計呈現灰色。
  • 在 Corel DESIGNER 中,當您停用「成比例」選項,按一下其中一個方塊旁的「設定度量」互動式按鈕,然後按一下另一個方塊旁的「設定度量」時,「變形」泊塢視窗的「大小」標籤上「W」「H」方塊中的值不會再隨之更新。
  • 「變形」泊塢視窗的「大小」標籤上啟用「成比例」選項,以互動方式設定寬度,然後以互動方式設定高度的操作現在可正常運作。

更新 1

全新功能與增強功能

CorelDRAW Technical Suite 2022 年更新 1 (v24.1) 僅適用於訂閱者和目前擁有有效的 CorelSure 維護服務的授權持有人,此次更新在 CorelDRAW 和 Corel DESIGNER 中的數個區域提供增強功能:

  • 「歡迎」畫面 (「說明」>「歡迎」>「教學課程」) 中,取得根據您個人檔案問卷調查所推薦的個人化學習內容。
  • 「匯出」泊塢視窗中,按一下名稱標籤並輸入新名稱,即可重新命名資產或頁面。
  • 按一下「說明」>「提交想法和回饋」,即可透過線上入口網站提交與 CorelDRAW Technical Suite 相關的評論或建議。此入口網站僅提供英文版。您可以自訂「提交想法和回饋」功能表指令,並將變更儲存於自訂工作區。
  • 如果在「學習」泊塢視窗的「探索」標籤中搜尋查詢的關鍵字沒有完全相符的結果,系統會跳出訊息,說明應用程式將顯示類似字詞或字元的搜尋結果。
  • 「學習」泊塢視窗的「探索」標籤中搜尋功能表指令時,搜尋結果現在會列出所有可存取該指令的相關位置。
  • 現在您在「學習」泊塢視窗的「探索」標籤中搜尋功能表指令時,存取指令位置的清單會優先顯示功能表列,再列出內容功能表列。
  • 「學習」泊塢視窗的「探索」標籤中搜尋功能表指令時,搜尋結果現在將會包含指令的完整路徑。
  • 為了改善 CorelDRAW 和 Corel PHOTO-PAINT 的版面,我們已在個人檔案問卷調查的最後一頁增加文字兩側的邊距。
  • 在個人化問卷調查的最後一個頁面中,系統會顯示訊息,說明應用程式正在根據您的個人檔案來更新推薦給您的學習資源清單。

效能與穩定度

CorelDRAW Technical Suite 2022 年更新 1 (v24.1) 也針對一些客戶回報的問題進行效能和穩定度修正。

  • 現在,在「EPS 匯出」對話方塊的「進階」標籤上啟用「頁面」選項後,若將檔案儲存成 EPS 格式並在 Corel PHOTO-PAINT 中開啟,該文件將擁有正確的頁面大小。
  • 在 Windows 10 和 Windows 11 上使用 Win+SHIFT+S 鍵盤快捷鍵來擷取螢幕畫面時,現在可以將剪貼簿內容貼至 CorelDRAW 文件中。
  • 將文件匯出成 EPS 格式時,套用合併模式 (例如「如果較暗」) 且具有透明度的曲線將不會再點陣化。
  • JPEG 壓縮斑點移除功能現在可正常運作。
  • UsePageBoundingBox 屬性已新增至 PDFVBASettings 類別,「PDF 匯出頁面大小」設定 (「PDF 設定」>「一般」) 的指令碼處理現已可正常運作。
  • 使用 VBA 指令碼設定外框屬性時,CorelDRAW 會正常變更外框寬度。
  • 我們已解決移動物件時與縮放及平移相關的效能和穩定度問題。
  • 我們已從 CorelDRAW 中 Adobe Illustrator 工作區的工具箱移除無法運作的工具和其他無需使用的指令。
  • 當您在不同的工作階段從「選項」(「工具」>「選項」>「色彩」) 對話方塊中選擇 PANTONE® 色盤時,CorelDRAW 現在會記住您所選的色盤。
  • 「學習」泊塢視窗的「探索」標籤搜尋欄位中輸入「/」、「%」等特殊字元時,不會再發生「找不到頁面」的錯誤。
  • 現在使用土耳其、荷蘭和瑞典版應用程式時,「學習」泊塢視窗會顯示英文學習資源清單。
  • 「學習」泊塢視窗的「探索」標籤中按一下滑鼠右鍵時,將不會再依設計顯示內容功能表。
  • 在以下情況中,「學習」泊塢視窗的「探索」標籤中的搜尋結果將不會消失:在啟用「探索」標籤時變更主題,切換至「提示」標籤後再切換回「探索」標籤。
  • 當 CorelDRAW Technical Suite 企業版使用者透過 corel.com 或企業版 Microsoft 365 帳戶登入 CorelDRAW.app,並開啟儲存於雲端的 CorelDRAW (CDR) 檔案時,現在已可正常存取專案儀表板。
  • 當您在「學習」泊塢視窗的「探索」標籤中進行搜尋,且搜尋結果與查詢字串完全相符時,如果您向下捲動至清單末端再捲動回到清單頂端,系統將不會再顯示沒有相符結果的錯誤訊息。
  • 如果您在「學習」泊塢視窗的「探索」標籤中清除搜尋,或在載入查詢結果的過程中選擇其他篩選器,應用程式不會再顯示錯誤的搜尋結果。
  • 對於列在「學習」泊塢視窗的「探索」標籤中的提示影片,我們已解決隱藏字幕未翻譯的問題。
  • 若要開啟 CorelDRAW (CDR)、Corel DESIGNER (DES) 或 Corel PHOTO-PAINT (CPT) 檔案,現在只需對該檔案按兩下,或在「檔案總管」中按一下滑鼠右鍵、按下「開啟方式」,然後分別選擇 CorelDRAW、Corel DESIGNER 或 Corel PHOTO-PAINT 即可。
  • 對連結群組的點陣圖套用下落式陰影、封套或透視效果的功能現已停用。若要對連結群組的點陣圖套用下落式陰影、封套或透視效果,必須先將點陣圖和這類特效建立群組。