Note sulla versione dell’aggiornamento 2022 di CorelDRAW Technical Suite

Aggiornamento per la sicurezza (15-12-2022)

L’aggiornamento per la sicurezza di CorelDRAW Technical Suite 2022 (v24.2.1) include correzioni per le vulnerabilità riportate dalla Zero Day Initiative (ZDI).

  • ZDI-22-1468 - Vulnerabilità di divulgazione delle informazioni in lettura fuori dai limiti nell’analisi dei file GIF
  • ZDI-22-1469 - Vulnerabilità di divulgazione delle informazioni in lettura fuori dai limiti nell’analisi dei file BMP
  • ZDI-22-1470 - Vulnerabilità di divulgazione delle informazioni in lettura fuori dai limiti nell’analisi dei file JP2
  • ZDI-22-1471 - Vulnerabilità nell’esecuzione del codice remoto per sovraccarico del buffer basato su stack nell’analisi dei file CGM
  • ZDI-22-1472 - Vulnerabilità nell’esecuzione del codice remoto in scrittura fuori dai limiti nell’analisi dei file GIF
  • ZDI-22-1473 - Vulnerabilità di divulgazione delle informazioni in lettura fuori dai limiti nell’analisi dei file PDF
  • ZDI-22-1474 - Vulnerabilità di divulgazione delle informazioni in lettura fuori dai limiti nell’analisi dei file EMF
  • ZDI-22-1475 - Vulnerabilità nell’esecuzione del codice remoto in scrittura fuori dai limiti nell’analisi dei file PCX
  • ZDI-22-1476 - Vulnerabilità nell’esecuzione del codice remoto in scrittura fuori dai limiti nell’analisi dei file PCX

Aggiornamento di settembre 2022

Funzionalità nuove e perfezionate

Disponibile esclusivamente per gli utenti con una sottoscrizione e una licenza con piano CorelSure Maintenance attivo, l’aggiornamento di CorelDRAW Technical Suite di settembre 2022 (v24.2) offre nuove funzionalità e ottimizzazioni in diverse aree di Corel DESIGNER, CorelDRAW e Corel PHOTO-PAINT:

Novità e ottimizzazioni! Creazione di una finestra di dialogo Nuovo documento

La finestra di dialogo Crea un nuovo documento è stata riprogettata per offrire una posizione centrale dalla quale iniziare i nuovi disegni. La finestra di dialogo ora include due schede, Impostazioni documento e Modelli, per consentire di passare da una vista all’altra con facilità.

Nella scheda Impostazioni documento (File > Nuovo), è possibile iniziare un disegno da zero specificando le impostazioni del documento o scegliendo un’impostazione predefinita. CorelDRAW e Corel DESIGNER consentono di cercare ed esplorare un'ampia scelta di impostazioni predefinite di stampa, per il web, specifiche del dispositivo e per i social media. Le impostazioni predefinite includono le dimensioni e l'orientamento della pagina, la modalità colore primario, le unità di misura e la risoluzione. Ad esempio, l’impostazione predefinita Copertina di LinkedIn nella categoria Social usa i pixel anziché i pollici, l’orientamento orizzontale, i colori RGB e presenta le dimensioni necessarie per un’immagine di copertina su LinkedIn. Per trovare più facilmente le impostazioni predefinite, CorelDRAW e Corel DESIGNER consentono di filtrarle per categoria e tipo di pagina e di organizzarle per nome, data e dimensioni della pagina.

Nella scheda Modelli (File > Nuovo da modello), è possibile iniziare un disegno da un modello. Le interfacce per filtrare e ordinare i modelli, nonché per accedere alle cartelle locali e di rete, sono state riorganizzate per consentire di trovare rapidamente i modelli necessari.

Novità! Progetti per fare pratica

I progetti per fare pratica sono raccolte di file di CorelDRAW (CDR) e Corel PHOTO-PAINT (CPT) che possono essere scaricati e usati per l'apprendimento, la formazione o le demo. Queste nuove esercitazioni interne all’applicazione possono essere usate per fare pratica con i concetti di base e perfezionare le proprie abilità. Oltre alla versione completata del progetto consultabile come riferimento, ogni esercitazione include una versione parzialmente completata con istruzioni dettagliate, per rendere l'esperienza interattiva e portare a termine ogni progetto. I progetti per fare pratica sono disponibili nella scheda Esplora della finestra mobile Impara. Completando il sondaggio del profilo utente, si ottengono consigli sui progetti per fare pratica adatti al proprio livello di abilità e alle proprie esigenze di progettazione.

Novità! Supporto del formato di file Google Web Picture (*.webp).

CorelDRAW, Corel DESIGNER e Corel PHOTO-PAINT offrono ora supporto del formato di file Google Web Picture (*.webp). Questo formato standard aperto sviluppato da Google fornisce una compressione di tipo lossless e lossy per le immagini progettate per l'uso sul web. Le immagini WEBP lossless sono più piccole delle immagini PNG e le immagini WEBP lossy sono più piccole delle immagini JPEG. I file WEBP possono essere importati come qualsiasi altro file supportato. Quando si esporta un file in formato WEBP, si può scegliere tra diverse impostazioni predefinite in base alle proprie esigenze o creare una nuova impostazione predefinita e salvarla per usarla in futuro. Le impostazioni avanzate, come la qualità e il rapporto di compressione, offrono flessibilità e controllo sul fattore di compressione per i canali RGB e sul rapporto tra velocità di codifica, dimensione del file e qualità, rispettivamente. La trasparenza dell'immagine viene mantenuta sia in importazione che in esportazione.

Novità! Ritaglio della grafica ai bordi della pagina durante l'esportazione

Ora, quando si esportano i file nei formati PNG, JPEG, GIF e WEBP, gli elementi grafici possono essere ritagliati sui bordi della pagina del disegno per rimuovere gli oggetti indesiderati e ridurre le dimensioni del file.

Interfaccia utente aggiornata in Windows 11

Per allinearsi meglio con la nuova interfaccia utente di Windows 11, questo aggiornamento presenta angoli arrotondati nella finestra dell'applicazione e nelle finestre di dialogo, ombre nelle finestre di dialogo, una nuova barra del titolo dell'applicazione e layout di snap.

Perfezionato! Finestra mobile Esporta

Questo aggiornamento introduce una gamma di funzionalità e ottimizzazioni alla finestra mobile Esporta per migliorare il flusso di lavoro. Le risorse e le pagine possono ora essere esportate in tre formati aggiuntivi: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG) e AutoCAD Drawing Interchange Format (DXF). Per comodità, le risorse e le pagine possono essere rinominate direttamente nella finestra mobile Esporta. Inoltre, il pulsante Esporta diventa disattivo quando non è selezionato nessun elemento.

Novità! Strumenti di ridimensionamento

CorelDRAW e Corel DESIGNER consentono di modificare facilmente la scala di una parte di un oggetto o di un'immagine portandolo una dimensione specifica. Lo strumento Scala porzione consente di ridimensionare una porzione di un oggetto per adattarla alla dimensione desiderata. Ad esempio, se occorre che una porta sia alta due metri, basta specificare quel valore e quindi trascinare verticalmente lungo la porta per ridimensionarla. Si può anche usare lo strumento interattivo di adattamento al riferimento, che offre una maggiore precisione quando si ridimensiona un oggetto per adattarlo a un altro oggetto. Ad esempio, questo nuovo pratico strumento consente di ridimensionare e spostare contemporaneamente una vite per adattarla perfettamente a un dado specifico.

Novità! Anteprima degli hotspot CGM

Corel DESIGNER introduce un nuovo pulsante Mostra/nascondi gli hotspot CGM per determinare istantaneamente quali oggetti contengono dati oggetto CGM. Un interruttore rapido evidenzierà gli hotspot con un tipico tratteggio blu, così non sarà necessario passare in rassegna gli oggetti uno per uno per identificare gli hotspot CGM. Ciò è particolarmente pratico per lavorare con contenuti S1000D che includono dati oggetto CGM interattivi.

Novità! Aggiunte macro e API

Una nuova macro e API (setCGMregion) inclusa in Corel DESIGNER consente agli utenti di aggiungere rapidamente i dati degli oggetti per definire gli oggetti che soddisfano le specifiche CGM. La combinazione di macro e API offre flessibilità, consentendo agli utenti di modificare la funzionalità della macro in base alle proprie esigenze.

Novità! Eliminazione dei dati degli oggetti dai gruppi nidificati

Quando si lavora con elementi e gruppi di elementi che contengono metadati in Corel DESIGNER, ora è possibile cancellare i dati da un singolo oggetto o dall'intero gruppo. Ciò è utile quando si scambiano file o progetti parziali che contengono metadati sensibili che non si desidera condividere.

Prestazioni e stabilità

L’aggiornamento di CorelDRAW Technical Suite di settembre 2022 (v24.1) include anche correzioni a livello di prestazioni e stabilità per diversi problemi riportati dagli utenti.

  • Quando si annulla il raggruppamento di oggetti, il loro ordine di sovrapposizione nella finestra mobile Oggetti viene mantenuto come previsto.
  • Quando si stampa su una stampante PostScript indipendente dal dispositivo, il nome del documento viene ora visualizzato nella casella Nome file della finestra di dialogo Stampa su file.
  • Le proprietà del carattere e della formattazione del testo nei PDF importati vengono ora mantenute indipendentemente dalle impostazioni del carattere e della formattazione per incollare e importare il testo dai formati di file di testo.
  • Ora si riesce a incollare un'immagine di Corel PHOTO-PAINT in un documento di CorelDRAW o Corel DESIGNER utilizzando il comando Modifica > Incolla speciale e scegliendo Corel PHOTO-PAINT 2022 Image.
  • Menu e strumenti vuoti, duplicati o non funzionali sono stati rimossi dall'area di lavoro di Adobe Illustrator in CorelDRAW.
  • Quando si cercano modelli nella scheda Modelli della finestra di dialogo Crea un nuovo documento, se si immette una query di ricerca che non restituisce alcun risultato, è possibile cancellare i termini di ricerca senza premere Invio. Quando si chiude la finestra di dialogo, la prossima volta che viene aperta, l'elenco dei modelli disponibili apparirà come previsto.
  • L'applicazione ora ricorda l'ultimo modello selezionato nella scheda Modelli della finestra di dialogo Crea un nuovo documento quando si chiude la finestra di dialogo e la si riapre durante la stessa sessione di lavoro.
  • Quando si seleziona un modello nella scheda Modelli della finestra di dialogo Crea un nuovo documento, se si immette una query di ricerca e si preme Invio, la finestra di dialogo non si chiude più.
  • Dopo aver riavviato l'applicazione in una lingua diversa e aver completato il sondaggio del profilo utente, le risorse di apprendimento consigliate non includono più argomenti della guida del prodotto predefiniti.
  • La ridenominazione di un modello nella scheda Modelli della finestra di dialogo Crea un nuovo documento e la successiva modifica delle dimensioni delle miniature, il passaggio del mouse su una miniatura o il passaggio da un modello all'altro non comporta più la visualizzazione errata del nuovo nome file.
  • Quando si rinomina, si ordina o si filtrano i modelli, si passa alla scheda Impostazioni documento e quindi si torna alla scheda Modelli della finestra di dialogo Crea un nuovo documento, l'ordinamento dei modelli viene ora mantenuto.
  • Dopo aver eliminato una risorsa o un modello contrassegnato come preferito o aver modificato la sua posizione, l'elemento non viene più visualizzato quando si ordinano o si filtrano gli elementi nella finestra mobile Risorse o nella scheda Modelli della finestra di dialogo Crea un nuovo documento.
  • Il comando di menu Collegamento (Oggetto > Collegamento) è stato ora rimosso dal menu Oggetto e da altri elementi dell'interfaccia utente nell'applicazione in quanto riguarda la funzionalità OLE obsoleta, che non è più supportata.
  • Quando si esportano più documenti come un unico PDF, la posizione dei simboli viene mantenuta.
  • La qualità delle bitmap viene mantenuta quando si aprono e salvano nuovamente i file SVG con le bitmap.
  • La trasparenza nelle bitmap viene mantenuta durante l'esportazione di file in formato SVG.
  • L'importazione e l'esportazione di andata e ritorno di file EPS con riempimenti a motivo a due colori non causa più l'interruzione della risposta di CorelDRAW o Corel DESIGNER.
  • L’aumento o la riduzione della larghezza di un oggetto dopo aver applicato la prospettiva ora funziona come previsto.
  • Quando si utilizza lo strumento Cerchio raggio centrale in Corel DESIGNER, il valore nella casella di riepilogo Cerchio raggio centrale sulla barra delle proprietà viene aggiornato correttamente quando si modifica la scala del disegno o la risoluzione in pixel del documento.
  • Il numero massimo di caratteri che è ora possibile inserire per il nome o la descrizione di un simbolo è 255.
  • I richiami non sono più danneggiati quando si importa un file con richiami in un documento che contiene già richiami.
  • Per garantire la coerenza in un documento, gli angoli smussati ora funzionano in modo identico sia nei richiami a più tratti che nelle linee con aloni.
  • Quando si utilizza la numerazione incrementale nel testo del richiamo in Corel DESIGNER, ora è possibile specificare un valore iniziale maggiore di 100.
  • Gli artefatti visivi non vengono più visualizzati durante il ridimensionamento o lo spostamento di richiami formattati con gruppi di stili in Corel DESIGNER.
  • Gli aloni ora vengono visualizzati nella posizione corretta dopo aver applicato gli stili ai richiami.
  • Gli hotspot ora vengono visualizzati nella posizione corretta dopo aver spostato o ridimensionato gli oggetti con gli hotspot e averli quindi esportati in CGM.
  • Le coordinate dell'hotspot vengono aggiornate correttamente quando si sposta un richiamo o se ne modifica la forma in Corel DESIGNER.
  • I problemi di esportazione di file con metadati XVL in formato CGM in Corel DESIGNER sono stati risolti.
  • Gli hotspot non vengono più visualizzati né sulla linea guida né sul testo del richiamo in Corel DESIGNER.
  • I problemi relativi all'esportazione del testo in XLIFF 2.0 in Corel DESIGNER sono stati risolti.
  • Corel DESIGNER ora visualizza un'anteprima dinamica quando si abilita l'opzione di adattamento alla casella nella scheda Scala e rifletti della finestra mobile Trasforma e si trascina per specificare un'area rettangolare in cui ridimensionare un oggetto selezionato.
  • In Corel DESIGNER, quando si abilita l'opzione di adattamento alla casella nella scheda Scala e rifletti della finestra mobile Trasforma per specificare un'area rettangolare in cui ridimensionare un oggetto selezionato, i pulsanti Rifletti orizzontalmente e Rifletti verticalmente sono disattivati in modo predefinito.
  • In Corel DESIGNER, i valori nelle caselle L or A nella scheda Dimensioni della finestra mobile Trasforma non vengono più aggiornati quando si disabilita l'opzione Proporzionale, si fa clic sul pulsante Imposta quote in modo interattivo accanto a una delle caselle, quindi si fa clic su Imposta quote in modo interattivo pulsante accanto all'altra casella.
  • L'attivazione dell'opzione Proporzionale nella scheda Dimensioni della finestra mobile Trasforma, l’impostazione della larghezza in modo interattivo e quindi l’impostazione dell'altezza in modo interattivo ora funzionano come previsto.

Aggiornamento 1

Funzionalità nuove e perfezionate

Disponibile esclusivamente per gli utenti con una sottoscrizione e una licenza con programma CorelSure Maintenance attivo, l’aggiornamento 1 di CorelDRAW Technical Suite (v24.1) apporta ottimizzazioni a diverse aree di CorelDRAW e Corel DESIGNER:

  • Accesso a contenuti formativi personalizzati basati sul sondaggio sul profilo nella schermata di Benvenuto (Guida > Benvenuto > Esercitazioni).
  • Possibilità di rinominare una risorsa o una pagina nella finestra mobile Esporta facendo clic sull’etichetta del nome e inserendo un nuovo nome.
  • Invio di commenti o suggerimenti su CorelDRAW Technical Suite tramite un portale online facendo clic su Guida > Invia idee e feedback. Il portale è disponibile solo in inglese. È possibile personalizzare il comando del menu Invia idee e feedback e salvare le modifiche in un’area di lavoro personalizzata.
  • Quando non ci sono corrispondenze esatte per una richiesta di ricerca nella scheda Esplora della finestra mobile Impara, un messaggio indica che l’applicazione mostrerà i risultati per parole o caratteri simili.
  • Quando si cercano comandi di menu nella scheda Esplora della finestra mobile Impara, i risultati della ricerca includono un elenco delle posizioni rilevanti per accedere ai comandi.
  • Ora quando si cercano comandi di menu nella scheda Esplora della finestra mobile Impara, la barra dei menu viene riportata prima della barra dei menu Contesto nell’elenco delle posizioni per l’accesso ai comandi.
  • Quando si cercano comandi di menu nella scheda Esplora della finestra mobile Impara, i risultati della ricerca ora includono il percorso completo dei comandi.
  • È stata aggiunta una spaziatura interna su entrambi i lati del testo nell’ultima pagina del sondaggio sul profilo in CorelDRAW e Corel PHOTO-PAINT per migliorare il layout.
  • Nell’ultima pagina del sondaggio sulla personalizzazione, un messaggio segnala che l’applicazione sta aggiornando l’elenco delle risorse formative consigliate in base al profilo.

Prestazioni e stabilità

L’aggiornamento 1 di CorelDRAW Technical Suite 2022 (v24.1) include anche correzioni a livello di prestazioni e stabilità per diversi problemi riportati dagli utenti.

  • Quando si attiva l’opzione Pagina nella scheda Avanzate della finestra di dialogo Esporta EPS, si salva un file in formato EPS e quindi lo si apre in Corel PHOTO-PAINT, ora le dimensioni delle pagine del documento risultano corrette.
  • Quando si cattura una schermata usando il tasto di scelta rapida Win+MAIUSC+S in Windows 10 e Windows 11, ora è possibile incollare i contenuti degli Appunti in un documento di CorelDRAW.
  • Le curve che hanno una trasparenza con applicata una modalità di unione (ad esempio “Se più scuro”) non vengono più rasterizzate quando si esporta un documento in formato EPS.
  • La rimozione degli artefatti della compressione JPEG ora funziona come previsto.
  • La proprietà UsePageBoundingBox è stata aggiunta alla classe PDFVBASettings e lo scripting delle impostazioni delle dimensioni della pagina in esportazione di PDF (Impostazioni PDF > Generale) ora funziona correttamente.
  • Quando si impostano le proprietà del contorno usando gli script VBA, CorelDRAW modifica la larghezza del contorno come previsto.
  • I problemi di prestazioni e stabilità con lo zoom e la panoramica durante l’animazione degli oggetti sono stati risolti.
  • Gli strumenti non funzionanti e altri comandi non necessari sono stati eliminati dalla casella degli strumenti nell’area di lavoro di Adobe Illustrator in CorelDRAW.
  • CorelDRAW ora ricorda la palette di colori PANTONE® che viene scelta nella finestra di dialogo Opzioni (Strumenti > Opzioni > Colore) da una sessione a un’altra.
  • L’inserimento di caratteri speciali, come / e %, nella scheda Esplora nella finestra mobile Impara non restituisce più un errore "Pagina non trovata".
  • Quando si usa l’applicazione in turco, olandese e svedese, la finestra mobile Impara ora mostra un elenco delle risorse di apprendimento in inglese.
  • Facendo clic con il pulsante destro del mouse nella scheda Esplora della finestra mobile Impara, il menu contestuale non è più disponibile per impostazione predefinita.
  • I risultati della ricerca nella scheda Esplora della finestra mobile Impara non scompaiono più nel seguente caso: quando la scheda Esplora è attiva, si cambia il tema, si passa alla scheda Suggerimenti e si torna alla scheda Esplora.
  • Gli utenti aziendali di CorelDRAW Technical Suite che accedono a CorelDRAW.app con un account corel.com o un account aziendale Microsoft 365 e aprono un file CorelDRAW (CDR) salvato nel Cloud ora possono accedere alla dashboard di progetto come previsto.
  • Quando si esegue una ricerca nella scheda Esplora della finestra mobile Impara, e i risultati della ricerca corrispondono esattamente alla richiesta di ricerca, non si vedrà più un messaggio di errore che indica che non sono state trovate corrispondenze esatte se si scorre l’elenco verso il basso fino alla fine e quindi si scorre in cima all’elenco.
  • L’applicazione non mostra più risultati di ricerca sbagliati nella scheda Esplora della finestra mobile Impara quando si annulla la ricerca o si sceglie un filtro diverso mentre i risultati della ricerca si stanno ancora caricando.
  • I problemi di mancata traduzione dei sottotitoli per non udenti sono stati risolti per i video Suggerimenti elencati nella scheda Esplora della finestra mobile Impara.
  • Ora è possibile aprire un file CorelDRAW (CDR), Corel DESIGNER (DES) o Corel PHOTO-PAINT (CPT) facendo doppio clic sul file o clic con il pulsante destro del mouse sul file in Esplora file, facendo clic su Apri con e scegliendo CorelDRAW, Corel DESIGNER o Corel PHOTO-PAINT rispettivamente.
  • Ora l’applicazione di un’ombra discendente, un involucro o una prospettiva alle bitmap che sono gruppi collegati è disabilitata. Per applicare un'ombra discendente, un involucro o una prospettiva alle bitmap che sono gruppi collegati, è necessario prima raggruppare le bitmap con gli effetti.