Notas de la versión de la Actualización de CorelDRAW Technical Suite 2022

Actualización de seguridad (15-12-2022)

La Actualización de seguridad de CorelDRAW Technical Suite 2022 (v24.2.1) incluye soluciones para vulnerabilidades comunicadas por Zero Day Initiative (ZDI).

  • ZDI-22-1468: vulnerabilidad de revelación de información por lectura fuera de límites al analizar archivos GIF
  • ZDI-22-1469: vulnerabilidad de revelación de información por lectura fuera de límites al analizar archivos BMP
  • ZDI-22-1470: vulnerabilidad de revelación de información por lectura fuera de límites al analizar archivos JP2
  • ZDI-22-1471: vulnerabilidad de ejecución remota de código por desbordamiento del búfer basado en pila al analizar archivos CGM
  • ZDI-22-1472: vulnerabilidad de ejecución remota de código por escritura fuera de límites al analizar archivos GIF
  • ZDI-22-1473: vulnerabilidad de revelación de información por lectura fuera de límites al analizar archivos PDF
  • ZDI-22-1474: vulnerabilidad de ejecución remota de código por lectura fuera de límites al analizar archivos EMF
  • ZDI-22-1475: vulnerabilidad de ejecución remota de código por escritura fuera de límites al analizar archivos PCX
  • ZDI-22-1476: vulnerabilidad de ejecución remota de código por escritura fuera de límites al analizar archivos PCX

Actualización de septiembre de 2022

Funciones nuevas y mejoradas

La Actualización de CorelDRAW Technical Suite de septiembre de 2022 (v24.2) se encuentra disponible exclusivamente para suscriptores y titulares de licencias con un plan de Mantenimiento CorelSure activo y ofrece nuevas funciones y mejoras en varias áreas de Corel DESIGNER, CorelDRAW y Corel PHOTO-PAINT:

¡Novedad y mejora! Cuadro de diálogo Crear un documento nuevo

Se ha rediseñado el cuadro de diálogo Crear un documento nuevo para proporcionar una ubicación central en la que iniciar dibujos nuevos. El cuadro de diálogo ahora tiene dos fichas, Configuración de documento y Plantillas, para poder cambiar de vista con facilidad.

En la ficha Configuración de documento (Archivo > Nuevo) se puede iniciar un dibujo en blanco especificando opciones de configuración del documento o eligiendo un preestablecido. CorelDRAW y Corel DESIGNER permiten buscar y explorar una amplia selección de preestablecidos para impresión, web, dispositivos específicos y redes sociales. Entre los preestablecidos figuran configuraciones predefinidas para tamaño y orientación de página, modo de color primario, unidades de medida y resolución. Por ejemplo, el preestablecido Portada de LinkedIn de la categoría Social usa píxeles en lugar de pulgadas, orientación horizontal, color RGB y tiene las dimensiones necesarias para una imagen de portada de LinkedIn. Para facilitar la búsqueda de preestablecidos, CorelDRAW y Corel DESIGNER permiten filtrarlos por categoría y tipo de página y ordenarlos por nombre, fecha y tamaño de página.

En la ficha Plantillas (Archivo > Nuevo con plantilla) puede iniciar un dibujo a partir de una plantilla. Se han reorganizado tanto las interfaces para filtrar y ordenar plantillas como las interfaces para acceder a las carpetas locales y de red para ayudarle a encontrar rápidamente las plantillas que necesita.

¡Novedad! Proyectos de práctica

Los proyectos de práctica son colecciones de archivos e CorelDRAW (CDR) y Corel PHOTO-PAINT (CPT) que puede descargar para aprendizaje, formación o demostraciones. Puede utilizar estos nuevos tutoriales integrados para practicar conceptos básicos y mejorar sus conocimientos. Además de la versión completada del proyecto que puede consultar como referencia, cada tutorial incluye una versión completada parcialmente y enriquecida con instrucciones paso a paso para que la experiencia sea interactiva y ayudarle a completar correctamente el proyecto. Puede acceder y explorar proyectos de práctica en la ficha Explorar de la ventana acoplable Aprender. Complete la encuesta de perfil de usuario para obtener recomendaciones de proyectos de práctica adecuados a su nivel de conocimientos y necesidades de diseño.

¡Novedad! Compatibilidad con el formato de archivo de imagen para Web de Google (*.webp)

CorelDRAW, Corel DESIGNER, y Corel PHOTO-PAINT ahora ofrecen compatibilidad con el formato de archivo de imagen para Web de Google (*.webp). Este formato estándar abierto creado por Google proporciona compresión con y sin pérdida para imágenes diseñadas para ser usadas en Internet. Las imágenes sin pérdida WEBP son más pequeñas que las imágenes PNG y las imágenes con pérdida WEBP son más pequeñas que las imágenes JPEG. Puede importar archivos WEBP como si se tratase de cualquier otro archivo compatible. Al exportar un archivo al formato WEBP, puede elegir entre varios preestablecidos en función de sus necesidades o crear un nuevo preestablecido y guardarlo para usarlo posteriormente. Las opciones avanzadas de configuración, como la calidad y la proporción de compresión, le ofrecen flexibilidad y control sobre el factor de compresión para canales RGB y la proporción entre la velocidad de codificación, el tamaño de archivo y la calidad, respectivamente. La transparencia de imagen se mantiene tanto en la importación como en la exportación.

¡Novedad! Recorte de diseños a los límites de página al exportar

Ahora cuando exporta archivos a los formatos PNG, JPEG, GIF y WEBP, puede recortar su diseño para ajustarlo a los límites de la página de dibujo y así quitar objetos no deseados y reducir el tamaño de archivo.

Interfaz de usuario actualizada en Windows 11

Para mejorar la alineación con la interfaz de usuario de Windows 11 actualizada esta actualización incluye esquinas redondeadas en la ventana de la aplicación y los cuadros de diálogo, sombras en los cuadros de diálogo, una nueva barra de título de la aplicación y diseños de encaje.

¡Mejora! Ventana acoplable Exportar

Esta actualización aporta una gama de funciones y mejoras a la ventana acoplable Exportar para mejorar el flujo de trabajo. Ahora los activos y las páginas pueden exportarse a tres formatos adicionales: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG) y AutoCAD Drawing Interchange Format (DXF). Para su comodidad, a los activos y las páginas se les puede cambiar el nombre directamente en la ventana acoplable Exportar. Además, el botón Exportar aparece atenuado cuando no está seleccionado ningún elemento.

¡Novedad! Herramientas de escala

CorelDRAW y Corel DESIGNER permiten escalar fácilmente una parte de un objeto o imagen a un tamaño específico. La herramienta Ajustar escala de porción de ahorro de tiempo le permite cambiar el tamaño de una porción de un objeto para ajustarla a una dimensión deseada. Por ejemplo, si necesita que una puerta tenga dos metros de altura, basta con que especifique ese valor y luego arrastre verticalmente por la puerta para escalarla. También puede usar la herramienta interactiva Encajar en referencia, que ofrece mayor precisión a la hora de cambiar el tamaño de un objeto para que encaje en otro objeto. Por ejemplo, esta práctica herramienta nueva le permite escalar y mover un tornillo simultáneamente para que encaje a la perfección en una tuerca específica.

¡Novedad! Previsualización de zonas interactivas CGM

Corel DESIGNER introduce un nuevo botón Mostrar/Ocultar zonas interactivas CGM para ayudarle a determinar al instante los objetos que contienen datos de objeto CGM. Al presionar el botón se muestran las zonas interactivas con un sombreado azul característico, eliminando así el laborioso proceso de examinar los objetos uno a uno para identificar las zonas interactivas CGM. Esto resulta especialmente práctico a la hora de trabajar con contenido S1000D que contiene datos de objetos CGM interactivos.

¡Novedad! Adiciones de macro y API

La nueva macro y API (setCGMregion) que incluye Corel DESIGNER ayuda a los usuarios a añadir rápidamente datos de objeto para definir objetos que satisfagan las especificaciones CGM. La combinación de macro y API ofrece flexibilidad al permitir a los usuarios cambiar la funcionalidad de la macro para adaptarla a sus necesidades.

¡Novedad! Borrar datos de objeto de grupos anidados

Al trabajar con elementos y grupos de elementos que contengan metadatos en Corel DESIGNER, ahora dispone de la opción de borrar datos de un único objeto o del grupo entero. Esto resulta beneficioso al intercambiar archivos o diseños parciales que contienen metadatos confidenciales que no desea compartir.

Rendimiento y estabilidad

La Actualización de CorelDRAW Technical Suite de septiembre de 2022 (v24.2) también incluye correcciones de rendimiento y estabilidad para varios problemas de los que nos han informado nuestros usuarios.

  • Al deshacer el agrupamiento de objetos, se mantiene correctamente su orden de apilamiento en la ventana acoplable Objetos.
  • Al imprimir en una impresora PostScript independiente de dispositivo, ahora se muestra el nombre de documento en el cuadro Nombre de archivo del cuadro de diálogo Imprimir en archivo.
  • Ahora se mantienen las propiedades de fuente y formato del texto en PDF importados, independientemente de la configuración de fuente y formato para pegar e importar texto de formatos de archivo de texto.
  • Ahora funciona correctamente pegar imágenes de Corel PHOTO-PAINT en documentos de CorelDRAW o Corel DESIGNER mediante el comando Editar > Pegado especial, Imagen de Corel PHOTO-PAINT 2022.
  • Los menús y herramientas en blanco, duplicados o que no funcionan se han eliminado del espacio de trabajo Adobe Illustrator de CorelDRAW.
  • Al buscar plantillas en la ficha Plantillas del cuadro de diálogo Crear un documento nuevo, si escribe una consulta de búsqueda que no devuelve ningún resultado, puede borrar los términos de búsqueda sin presionar Intro. Cierre el cuadro de diálogo y, la próxima vez que lo abra, se mostrará correctamente la lista de plantillas disponibles.
  • Ahora la aplicación recuerda la última plantilla seleccionada en la ficha Plantillas del cuadro de diálogo Crear un documento nuevo cuando se cierra el cuadro de diálogo y se vuelve a abrir durante la misma sesión de trabajo.
  • Al seleccionar una plantilla en la ficha Plantillas del cuadro de diálogo Crear un documento nuevo y, a continuación, escribir una consulta de búsqueda y presionar Intro, ya no se cierra el cuadro de diálogo.
  • Tras volver a lanzar la aplicación en otro idioma y completar la encuesta de perfil de usuario, los recursos de aprendizaje recomendados ya no incluyen temas de la ayuda del producto de manera predeterminada.
  • Al cambiar de nombre una plantilla en la ficha Plantillas del cuadro de diálogo Crear un documento nuevo y luego cambiar el tamaño de las miniaturas, cuando se sitúa el cursor sobre una miniatura o se cambia de una plantilla a otra, ya no se muestra incorrectamente el nuevo nombre de archivo.
  • Al cambiar de nombre, ordenar o filtrar plantillas y luego cambiar a la ficha Configuración de documento para, a continuación, cambiar a la ficha Plantillas del cuadro de diálogo Crear un documento nuevo, ahora se mantiene el orden de clasificación de las plantillas.
  • Tras eliminar un activo o plantilla que estaba marcado como favorito, o al cambiar su ubicación, el elemento deja de mostrarse al ordenar o filtrar elementos en la ventana acoplable Activos o la ficha Plantillas del cuadro de diálogo Crear un documento nuevo.
  • El comando de menú Enlazar (Objeto > Enlazar) ahora se ha eliminado del menú Objeto y otros elementos de la interfaz de usuario de la aplicación en lo relativo a la funcionalidad OLE obsoleta, que ya no es compatible.
  • Al exportar varios documentos como un único PDF, se mantiene la posición de los símbolos.
  • Se mantiene la calidad de los mapas de bits al abrir y volver a guardar archivos SVG con mapas de bits.
  • Se mantiene la transparencia en los mapas de bits al exportar archivos al formato SVG.
  • La importación y exportación de ida y vuelta de archivos EPS con rellenos de patrón de dos colores ya no hacen que CorelDRAW o Corel DESIGNER dejen de responder.
  • Ahora funciona correctamente la opción de aumentar o reducir el ancho de un objeto tras aplicar perspectiva.
  • Al trabajar con la herramienta Círculo de radio central de Corel DESIGNER, el valor del cuadro de lista Círculo de radio central de la barra de propiedades se actualiza correctamente al cambiar la escala de dibujo o la resolución en píxeles del documento.
  • Ahora el número máximo de caracteres que se pueden especificar como nombre o descripción de un símbolo es de 255.
  • Las notas ya no están dañadas al importar un archivo con notas en un documento que ya contiene notas.
  • Para garantizar la coherencia de un documento, ahora las esquinas en inglete funcionan de manera idéntica, tanto en notas de varios tramos como en líneas con halos.
  • Al utilizar numeración incremental en texto de notas en Corel DESIGNER, ahora puede especificar un valor de Inicio superior a 100.
  • Ya no se muestran imperfecciones visuales al escalar o mover notas formateadas con conjuntos de estilos en Corel DESIGNER.
  • Ahora los halos se muestran en el lugar correcto tras aplicar estilos a notas.
  • Ahora las zonas interactivas se muestran en la posición correcta tras mover o escalar objetos con zonas interactivas y luego exportar a CGM.
  • Se actualizan correctamente las coordenadas de zonas interactivas al mover una nota o cambiar su forma en Corel DESIGNER.
  • Se han resuelto los problemas de exportación de archivos con metadatos XVL al formato CGM en Corel DESIGNER.
  • Las zonas interactivas ya no se muestran a la vez en la línea guía y el texto de nota en Corel DESIGNER.
  • Se han solucionado los problemas de exportación de texto a XLIFF 2.0 en Corel DESIGNER.
  • Corel DESIGNER ahora muestra una previsualización dinámica al activar la opción Encajar en el cuadro de la ficha Escalar y reflejar de la ventana acoplable Transformar y arrastrar para especificar un área rectangular a la que escalar un objeto seleccionado.
  • En Corel DESIGNER, al activar la opción Encajar en el cuadro de la ficha Escalar y reflejar de la ventana acoplable Transformar para especificar un área rectangular a la que escalar un objeto seleccionado, los botones Reflejar horizontalmente y Reflejar verticalmenteaparecen atenuados de manera predeterminada.
  • En Corel DESIGNER, ya no se actualizan los valores de los cuadros Ancho y Alto de la ficha Tamaño de la ventana acoplable Transformar al desactivar la opción Proporcional, hacer clic en el botón Establecer dimensiones de forma interactiva junto a uno de los cuadros y luego hacer clic en el botón Establecer dimensiones de forma interactiva junto al otro cuadro.
  • El funcionamiento es correcto al activar la opción Proporcional en la ficha Tamaño de la ventana acoplable Transformar, definir el ancho de manera interactiva y luego definir el alto de forma interactiva.

Actualización 1

Funciones nuevas y mejoradas

La Actualización 1 de CorelDRAW Technical Suite 2022 (v24.1) se encuentra disponible exclusivamente para suscriptores y titulares de licencias con Mantenimiento CorelSure activo y ofrece mejoras en varias áreas de CorelDRAW y Corel DESIGNER:

  • Acceda a contenido de aprendizaje personalizado basado en su encuesta de perfil de la Pantalla de inicio (Ayuda > Bienvenido > Tutoriales).
  • Cambie el nombre de un activo o página en la ventana acoplable Exportar haciendo clic en la etiqueta de nombre y especificando un nuevo nombre.
  • Envíe comentarios o sugerencias acerca de CorelDRAW Technical Suite a través de un portal en línea haciendo clic en Help (Ayuda) > Submit Ideas and Feedback (Enviar ideas y comentarios). El portal solo se encuentra disponible en inglés. Puede personalizar el comando de menú Submit Ideas and Feedback y guardar los cambios en un espacio de trabajo personalizado.
  • Cuando no hay coincidencias exactas para la consulta de búsqueda en la ficha Explorar de la ventana acoplable Aprender, un mensaje le notifica que la aplicación va a mostrar resultados para palabras o caracteres similares en su lugar.
  • Al buscar comandos de menú en la ficha Explorar de la ventana acoplable Aprender, los resultados de la búsqueda ahora incluyen una lista de todas las ubicaciones pertinentes para acceder a los comandos.
  • Ahora al buscar comandos de menú en la ficha Explorar de la ventana acoplable Aprender, la barra de menús aparece antes de la barra de menú contextual en la lista de ubicaciones para acceder a los comandos.
  • Al buscar comandos de menú en la ficha Explorar de la ventana acoplable Aprender, los resultados de la búsqueda ahora incluyen la ruta de acceso completa a los comandos.
  • Se ha añadido relleno a ambos lados del texto en la última página de la encuesta de perfil en CorelDRAW y Corel PHOTO-PAINT para mejorar el diseño.
  • En la última página de la encuesta de personalización, un mensaje le notifica que la aplicación va a actualizar la lista de recursos de aprendizaje recomendados en función de su perfil.

Rendimiento y estabilidad

La Actualización 1 de CorelDRAW Technical Suite 2022 (v24.1) también incluye correcciones de rendimiento y estabilidad para varios problemas de los que nos han informado nuestros usuarios.

  • Al activar la opción Página en la ficha Avanzadas del cuadro de diálogo Exportar EPS, guardar un archivo en el formato EPS y luego abrirlo en Corel PHOTO-PAINT, ahora el documento tiene el tamaño de página correcto.
  • Al tomar una captura de pantalla utilizando el acceso directo de teclado Win+MAYÚS+S en Windows 10 y Windows 11, ahora puede pegar el contenido del Portapapeles en un documento de CorelDRAW.
  • Las curvas que tienen transparencia con un modo de fusión (como por ejemplo "Si más oscuro") aplicado ya no se rasterizan al exportar un documento al formato EPS.
  • Ahora funciona correctamente la eliminación de distorsiones de compresión JPEG.
  • Se ha añadido la propiedad UsePageBoundingBox a la clase PDFVBASettings y los guiones de la configuración del tamaño de página de exportación de PDF (Configuración de PDF > General) ahora funcionan correctamente.
  • Al definir propiedades de contorno mediante guiones VBA, CorelDRAW cambia la anchura de contorno correctamente.
  • Se han resuelto los problemas de rendimiento y estabilidad de zoom y panorámica al mover objetos.
  • Las herramientas que no funcionan y otros comandos innecesarios se han quitado de la caja de herramientas del espacio de trabajo de Adobe Illustrator en CorelDRAW.
  • CorelDRAW ahora recuerda la paleta de colores PANTONE® que elija en el cuadro de diálogo Opciones (Herramientas > Opciones > Color) de una sesión a otra.
  • Al escribir caracteres especiales, como / y %, en el campo de búsqueda de la ficha Explorar de la ventana acoplable Aprender, ya no se produce un error de página no encontrada.
  • Al usar la aplicación en turco, neerlandés o sueco, la ventana acoplable Aprender ahora muestra una lista de recursos de aprendizaje en inglés.
  • Al hacer clic con el botón secundario en la ficha Explorar de la ventana acoplable Aprender, el menú contextual ya no se encuentra disponible de manera predeterminada.
  • Los resultados de búsqueda en la ficha Explorar de la ventana acoplable Aprender ya no desaparecen en el siguiente caso: con la ficha Explorar activa, cambie el tema, cambie a la ficha Sugerencias y luego vuelva a cambiar a la ficha Explorar.
  • Los usuarios corporativos de CorelDRAW Technical Suite que inicien sesión en CorelDRAW.app con su cuenta de corel.com o cuenta corporativa de Microsoft 365 y abran un archivo de CorelDRAW (CDR) guardado en la nube ahora pueden acceder al panel de control del proyecto correctamente.
  • Cuando realice una búsqueda en la ficha Explorar de la ventana acoplable Aprender y los resultados de la búsqueda coincidan exactamente con la consulta de búsqueda, ya no verá un mensaje de error indicando que no se encontraron coincidencias exactas si se desplaza al final de la lista y luego vuelve al principio de la lista.
  • La aplicación ya no muestra resultados de búsqueda incorrectos en la ficha Explorar de la ventana acoplable Aprender al borrar la búsqueda o elegir otro filtro mientras se están cargando todavía los resultados de la consulta.
  • Se han solucionado los problemas de subtítulos sin traducir en los vídeos de sugerencias que figuran en la ficha Explorar de la ventana acoplable Aprender.
  • Ahora puede abrir un archivo de CorelDRAW (CDR), Corel DESIGNER (DES) o Corel PHOTO-PAINT (CPT) haciendo doble clic en el archivo o haciendo clic con el botón secundario en el archivo en el Explorador de archivos, haciendo clic en Abrir con y eligiendo CorelDRAW, Corel DESIGNER o Corel PHOTO-PAINT, respectivamente.
  • Ahora está deshabilitada la aplicación de sombras, envolturas o perspectivas a mapas de bits que sean grupos enlazados. Para aplicar sombras, envolturas o perspectivas a mapas de bits que sean grupos enlazados, primero deberá agrupar los mapas de bits con los efectos.