CorelDRAW Graphics Suite 2022 Update (Windows and Mac) Release notes

September 2022 Update

New and Enhanced Features

Available exclusively to subscribers and licensees with an active CorelSure Maintenance plan, the CorelDRAW Graphics Suite September 2022 Update (v24.2) delivers new features and enhancements to several areas within CorelDRAW and Corel PHOTO-PAINT:

New and enhanced! Create a New Document dialog box

The Create a New Document dialog box has been redesigned to provide a central location for starting new drawings. The dialog box now has two tabs, Document Settings and Templates, so you can switch between views with ease.

On the Document Settings tab (File > New), you can start a blank drawing by specifying document settings or choosing a preset. CorelDRAW lets you search and browse a wide selection of print, web, device-specific, and social media presets. Presets include predefined settings for page size and orientation, primary color mode, units of measurement, and resolution. For example, the LinkedIn Cover preset from the Social category uses pixels instead of inches, landscape orientation, RGB color, and has the dimensions required for a LinkedIn cover image. To find presets more easily, CorelDRAW lets you filter them by category and page type and sort them by name, date, and page size.

On the Templates tab (File > New from Template), you can start a drawing from a template. The interfaces for filtering and sorting templates as well as accessing local and network folders have been reorganized to help you quickly find the templates you need.

New! Practice projects

Practice projects are collections of CorelDRAW (CDR) and Corel PHOTO-PAINT (CPT) files that you can download to use for learning, training, or demos. You can leverage these new in-app tutorials to practice basic concepts and refine your skills. In addition to the completed version of the project that you can consult for reference, each tutorial comes with a partially completed version, enriched with step-by-step instructions to make the experience interactive and help you complete the project successfully. You can access and browse practice projects on the Explore tab of the Learn docker (Windows) or Learn inspector (macOS). Complete the user profile survey to get recommendations for practice projects that match your skill level and design needs.

New! Support for the Google Web Picture (*.webp) file format

CorelDRAW and Corel PHOTO-PAINT now offer support for the Google Web Picture (*.webp) file format. This open standard format developed by Google provides lossless and lossy compression for images designed for use on the web. WEBP lossless images are smaller than PNGs, and WEBP lossy images are smaller than JPEG images. You can import WEBP files as you would any other supported files. When you export a file to the WEBP format, you can choose from several presets to suit your needs or create a new preset and save it for future use. Advanced settings, such as quality and compression ratio, give you flexibility and control over the compression factor for RGB channels and the ratio between encoding speed, file size, and quality, respectively. Image transparency is maintained on both import and export.

New! Cropping artwork to page boundaries on export

Now when you export files to PNG, JPEG, GIF, and WEBP formats, you can crop your artwork to the boundaries of the drawing page to remove unwanted objects and reduce file size.

Updated user interface on Windows 11

To better align with the updated Windows 11 user interface, this update features rounded corners on the application window and dialog boxes, dialog box shadows, a new application title bar, and snap layouts.

Enhanced! Export docker (Windows) or Export inspector (macOS)

This update introduces a range of features and enhancements to the Export docker (Windows) or Export inspector (macOS) to improve your workflow. Assets and pages can now be exported to three additional formats: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG), and AutoCAD Drawing Interchange Format (DXF). For your convenience, assets and pages can be renamed directly in the Export docker (Windows) or Export inspector (macOS). Plus, the Export button is grayed out when there are no items selected.

New! Scale tools

CorelDRAW lets you easily scale a portion of an object or image to a specific size. The time-saving Scale portion tool lets you resize a portion of an object to fit a desired dimension. For example, if you need a door to be seven feet tall, you simply specify that value and then drag vertically along the door to scale it. You can also use the interactive Fit to Reference tool, which offers greater accuracy when resizing an object to fit into another object. For example, this handy new tool lets you simultaneously scale and move a screw to fit perfectly into a specific nut.

Performance and Stability

CorelDRAW Graphics Suite September 2022 Update (v24.2) also includes performance and stability fixes for several customer-reported issues.

  • When you undo the grouping of objects, their stacking order in the Objects docker (Windows) or Objects inspector (macOS) is maintained as expected.
  • When you print to a device-independent PostScript printer, the document name now appears in the File name (Windows) or Save as (macOS) box of the Print to File dialog box.
  • The font and formatting properties of text in imported PDFs are now maintained regardless of the font and formatting settings for pasting and importing text from text file formats.
  • Pasting a Corel PHOTO-PAINT image into a CorelDRAW document by using the Edit > Paste Special command and choosing Corel PHOTO-PAINT 2022 Image now functions as designed.
  • Blank, duplicate, or nonfunctional menus and tools have been removed from the Adobe Illustrator workspace in CorelDRAW on Windows.
  • On macOS, CorelDRAW no longer stops responding when you quit the application after exporting a document to the DXF format.
  • On macOS, the captions of graphics on the Hints tab of the Learn inspector now appear white in Dark mode.
  • On macOS, the application functions as expected when the terms you enter in the search box on the Templates tab of the Create a New Document dialog box (CorelDRAW) and Assets inspector contain the following special characters: parentheses (), brackets [], braces {}, and +.
  • When searching for templates on the Templates tab of the Create a New Document dialog box on Windows, if you enter a search query that doesn't return any results, you can erase the search terms without pressing Enter,. When you close the dialog box, the next time you open it, the list of available templates will appear as expected.
  • The application now remembers the last selected template on the Templates tab of the Create a New Document dialog box when you close the dialog box and re-open it during the same working session.
  • When you select a template on the Templates tab of the Create a New Document dialog box on Windows, if you enter a search query, and press Enter, the dialog box no longer closes.
  • After relaunching the application in a different language and completing the user profile survey, the recommended learning resources no longer include topics from the product help by design.
  • Renaming a template on the Templates tab of the Create a New Document dialog box, and then changing the size of thumbnails, hovering over a thumbnail, or switching between templates no longer results in the incorrect display of the new filename.
  • When you rename, sort, or filter templates, then switch to the Document Settings tab, and then switch back to the Templates tab of the Create a New Document dialog box on Windows, the sorting order of templates is now maintained.
  • After you delete an asset or template that was marked as a favorite, or you change its location, the item no longer appears when sorting or filtering items on the Assets docker (Windows), Assets inspector (macOS), or the Templates tab of the Create a New Document dialog box.
  • The Link menu command (Object > Link) is now removed from the Object menu and other user interface elements in the application as it pertains to outdated OLE functionality, which is no longer supported.
  • Bitmap quality is maintained when opening and resaving SVG files with bitmaps.
  • When you export multiple documents as a single PDF on Windows, the position of symbols is maintained.
  • Transparency in bitmaps is maintained when exporting files to the SVG format.
  • The maximum number of characters that you can now enter for the name or description of a symbol is 255.
  • When you enable the Scale portion option on the Size tab of the Transform docker (Windows) or Transform inspector (macOS) in CorelDRAW, the line is constrained as expected. Just hold down Ctrl, and drag along an object to set scale.
  • On macOS, names that exceed 26 characters now display properly as you type in the Name box of the Create New Symbol dialog box on macOS (Object > Symbol > Create New Symbol).
  • Callouts are no longer corrupted when you import a file with callouts into a document that already contains callouts.
  • Roundtrip import and export of EPS files with two-color pattern fills no longer causes CorelDRAW on Windows to stop responding.
  • Increasing or decreasing the width of an object after applying perspective now works as expected.

Update 1

New and Enhanced Features

Available exclusively to subscribers and licensees with an active CorelSure Maintenance, the CorelDRAW Graphics Suite 2022 Update 1 (v24.1) brings enhancements to several areas in CorelDRAW:

  • Access personalized learning content based on your profile survey in the Welcome screen (Help > Welcome > Tutorials).
  • Rename an asset or page in the Export docker (Windows) or Export inspector (macOS) by clicking the name label and entering a new name.
  • Submit comments or suggestions about CorelDRAW Graphics Suite through an online portal by clicking Help > Submit Ideas and Feedback on Windows. The portal is available only in English. On Windows, you can customize the Submit Ideas and Feedback menu command and save the changes in a custom workspace.
  • If the application quits unexpectedly during a session on macOS, an error log report is automatically sent to Corel to help fix the problem and improve the application.
  • Padding has been added on both sides of the text on the last page of the profile survey to improve the layout.
  • When there are no exact matches for your search query in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), a message notifies you that the application will show results for similar words or characters instead.
  • When you search for menu commands in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the search results now include a list of all relevant locations for accessing the commands.
  • Now when you search for menu commands in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the Menu bar is listed before the Context menu bar in the list of locations for accessing the commands.
  • When you search for menu commands in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the search results now include the full path to the commands.
  • On the last page of the personalization survey, a message notifies you that the application is updating the list of recommended learning resources based on your profile.

Performance and Stability

CorelDRAW Graphics Suite 2022 Update 1 (v24.1) also includes performance and stability fixes for several customer-reported issues.

  • When you enable the Page option on the Advanced tab in the EPS Export dialog box, save a file to the EPS format, and then open it in Corel PHOTO-PAINT, the document now has the correct page size.
  • When you take a screen capture by using the Win+SHIFT+S keyboard shortcut on Windows 10 and Windows 11, you can now paste the contents of the Clipboard into a CorelDRAW document.
  • Curves that have transparency with a merge mode (such as 'If darker') applied to it are no longer rasterized when you export a document to the EPS format on Windows.
  • Removing JPEG compression artifacts now works as expected.
  • The UsePageBoundingBox property has been added to the PDFVBASettings class, and scripting of PDF Export Page size settings (PDF Settings > General) now works properly.
  • When setting outline properties by using VBA scripts on Windows, CorelDRAW changes the outline width as expected.
  • Performance and stability issues with zooming and panning when moving objects have been resolved.
  • Nonfunctional tools and other commands that are not needed have been removed from the toolbox in the Adobe Illustrator workspace on Windows.
  • CorelDRAW now remembers the PANTONE® color palette you choose in the Preferences (CorelDRAW menu > Preferences > Color on macOS) or Options (Tools > Options > Color on Windows) dialog box from one session to another.
  • Entering special characters, such as / and %, in the search field of the Explore tab in the Learn docker (Windows) or Learn inspector (macOS) no longer results in a "Page Not Found" error.
  • Issues with the appearance of rounded corners of the profile survey on macOS have been addressed.
  • When using the application in Turkish, Dutch, and Swedish, the Learn docker (Windows) or Learn inspector (macOS) now displays a list of learning resources in English.
  • When you right-click (Windows) or Control-click in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), the context menu is no longer available by design.
  • The search results in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS) no longer disappear in the following case: with the Explore tab active, change the theme, switch to the Hints tab, and then switch back to the Explore tab.
  • Corporate users of CorelDRAW Graphics Suite who sign in to CorelDRAW.app with their corel.com or corporate Microsoft 365 accounts and open a CorelDRAW (CDR) file saved to the Cloud can now access the project dashboard as expected.
  • When you perform a search in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS), and the search results match exactly your search query, you will no longer see an error message that no exact matches are found if you scroll down to the end of the list, and then scroll back to the top of the list.
  • The application no longer displays wrong search results in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS) when you clear the search or choose a different filter while the search results from your query are still loading.
  • On macOS, the application no longer stops responding if you access a flyout from the property bar, enter a value, press Enter, and then press Esc.
  • Issues with untranslated closed captions have been addressed for Hints videos that are listed in the Explore tab of the Learn docker (Windows) or Learn inspector (macOS).
  • On Windows, you can now open a CorelDRAW (CDR), Corel DESIGNER (DES), or Corel PHOTO-PAINT (CPT) file by double-clicking the file or right-clicking the file in File Explorer, clicking Open with, and choosing CorelDRAW, or Corel PHOTO-PAINT, respectively.
  • Applying a drop shadow, an envelope, or perspective to bitmaps that are linked groups is now disabled. To apply a drop shadow, an envelope, or perspective to bitmaps that are linked groups, you must first group the bitmaps with the effects.