CorelDRAW Technical Suite 2026 Updates
Release notes

The September 2026 Update for CorelDRAW® Technical Suite 2026 (v27.2) includes feature enhancements, as well as performance and stability fixes for several customer-reported issues.

AI image generation

  • In CorelDRAW and CorelDRAW Web, a new Quick AI Generate command has been added to the File menu, which opens a dialog box so you can quickly create or modify images with AI functionality.
  • The Welcome screen in CorelDRAW (Generate with AI) and the Home screen in CorelDRAW Web (Quick AI Generate) also provide one-click access to AI functionality.
  • The new Quick AI Generate dialog box in CorelDRAW and CorelDRAW Web includes a Create a vector button, which lets you create a scalable vector graphic from a text prompt.
  • In CorelDRAW and CorelDRAW Web, a new Create Vector Image tab has been added to the AI Generate docker so you can create scalable, editable vector graphics from text prompts.
  • In Corel PHOTO-PAINT, a new Quick AI Generate command has been added to the File menu, which opens a dialog box so you can quickly create or modify images with AI functionality.
  • The Welcome screen (Generate with AI) in Corel PHOTO-PAINT also provides one-click access to AI functionality.
  • In Corel PHOTO-PAINT, the AI Generate docker now includes an Import image button so you can more easily add reference content from your offline files when remixing an image.
  • The Generation in progress timeout for complex AI image generation and background removal has been extended to 60 seconds, limiting premature rendering failures and potential loss of AI credits.

PANOSE font matching

  • The Fonts Not Available dialog box (formerly "Substitute Missing or Unsupported Fonts") now uses clearer, more user-friendly wording and labels, making font replacement options easier to choose. In CorelDRAW on desktop, it appears when you open a document that uses fonts not present in the folders Corel Font Manager monitors. In CorelDRAW Web, it appears when you open a document that uses fonts not present in the font list.
  • You can toggle the Replacement options open or closed, and the application will remember the last-used state.

File format support

  • The XVL Studio 3D CAD Corel Edition September 2026 release offers updated version support for several native 3D CAD and exchange file formats.

Performance and stability

  • In CorelDRAW and Corel DESIGNER, you'll now receive instant visual previews of any transformation as you drag, rotate, stretch, or skew bitmap objects, including groups of bitmap objects.
  • In CorelDRAW, CorelDRAW Web, and Corel DESIGNER, the redesigned PowerTRACE UI provides new settings, improved color handling, and AI-assisted background removal for faster, state-of-the-art bitmap-to-vector conversion.
  • With CorelDRAW Web, you can upload TrueType (TTF) or OpenType (OTF) fonts from your system to Corel Cloud so you can always work with the same fonts that you use on your desktop.
  • In CorelDRAW Web, a new Quick Tutorial guides you step-by-step through generating and remixing AI images.
  • In CorelDRAW, occasional issues with stability during GPU initialization, in-product messaging, and security certificate warnings have been resolved.
  • The update also includes fixes for issues that some customers experienced when:
    • undoing grouping of objects in CorelDRAW
    • using Vector Trace in CorelDRAW
    • setting character Position in the Text docker in CorelDRAW
    • opening PDF files exported by Google in CorelDRAW
    • opening PDF files created by Canva in CorelDRAW
    • importing PDF files containing objects with intersecting curves in CorelDRAW
    • saving large files as background task in CorelDRAW
    • saving user changes to application options in CorelDRAW
    • creating PostScript output with crop marks in CorelDRAW
    • opening Corel DESIGNER files containing dimension text in CorelDRAW
    • opening Corel DESIGNER files containing callouts with text, backgrounds, and arrows in CorelDRAW
    • accessing Callout and Dimension style icons in the Object Styles docker in CorelDRAW
    • working with mirrored objects and Node reflection icons on the property bar in CorelDRAW
    • dragging guidelines in Corel PHOTO-PAINT
    • linking callouts to object data in Corel DESIGNER
    • clicking individual parts of a diagram in XVL Studio